summaryrefslogtreecommitdiff
path: root/pcr/gentoo-functions
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gentoo-functions')
-rw-r--r--pcr/gentoo-functions/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/pcr/gentoo-functions/PKGBUILD b/pcr/gentoo-functions/PKGBUILD
new file mode 100644
index 000000000..7ae9d92f0
--- /dev/null
+++ b/pcr/gentoo-functions/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer (Manjaro): artoo <artoo@manjaro.org>
+# Contributor (Manjaro): williamh <williamh@gentoo.org>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: Luke Shumaker <lukeshu@parabola.nu>
+
+# Gentoo's ebuild file:
+# https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+pkgname=gentoo-functions
+pkgver=0.12
+pkgrel=1
+pkgdesc="Base functions for Gentoo systems"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/gentoo/$pkgname"
+license=('GPL2')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/gentoo/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('4a6ddb1d8be7b52aae68761fb26546663b6b0e74b155df263cddfbfa72373965')
+
+_makeargs=(
+ ROOTPREFIX=/usr
+ ROOTSBINDIR=/usr/bin
+)
+
+build(){
+ cd "$srcdir/$pkgname-$pkgver"
+ make "${_makeargs[@]}"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" "${_makeargs[@]}" install
+}