summaryrefslogtreecommitdiff
path: root/pcr/gnome-rdp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gnome-rdp/PKGBUILD')
-rw-r--r--pcr/gnome-rdp/PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/pcr/gnome-rdp/PKGBUILD b/pcr/gnome-rdp/PKGBUILD
index c8f92134a..eb514675a 100644
--- a/pcr/gnome-rdp/PKGBUILD
+++ b/pcr/gnome-rdp/PKGBUILD
@@ -1,17 +1,21 @@
-# Contributor (Arch): György Balló <ballogy@freestart.hu>
-# Contributor (Arch): Hyperair <hyperair@gmail.com>
-# Contributor (Arch): kumico <norrian@gmail.com>
-# Contributor (Arch): adamruss <mail@russ.co.il>
+# Maintainer (AUR): Wayne Hartmann (DH4) <wayne@bitstorm.pw>
+# Contributor (AUR): György Balló <ballogy@freestart.hu>
+# Contributor (AUR): Hyperair <hyperair@gmail.com>
+# Contributor (AUR): kumico <norrian@gmail.com>
+# Contributor (AUR): adamruss <mail@russ.co.il>
# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
+# parabola changes and rationale:
+# no changes.
+
pkgname=gnome-rdp
pkgver=0.3.1.0
-pkgrel=1
+pkgrel=3
pkgdesc="Remote desktop client for the GNOME Desktop with RDP/VNC/SSH capabilities, written in C Sharp"
arch=('any')
url="http://sourceforge.net/projects/gnome-rdp/"
license=('GPL' 'LGPL')
-depends=('gtk-sharp-2' 'gnome-keyring-sharp')
+depends=('gtk-sharp-2' 'gnome-keyring-sharp' 'mono')
optdepends=('openssh: SSH client'
'gnome-terminal: required for the SSH client'
'rdesktop: RDP client'
@@ -19,7 +23,7 @@ optdepends=('openssh: SSH client'
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
appindicator.patch)
md5sums=('3c1329702914f8b1c213c0bb00d078cf'
- '7bbe98eadfe199c5664fd69a4531fb3d')
+ '480c69cab53fa79a015d0f2b7e1df9c4')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -29,6 +33,10 @@ build() {
sed -i 's|@expanded_libdir@|@prefix@/@libdir@|' gnome-rdp.in
autoreconf -fi
+ sed -i 's|GMCS|DMCS|g' configure
+ sed -i 's|gmcs|dmcs|g' configure
+ sed -i 's|GMCS|DMCS|g' Makefile.in
+ sed -i 's|gmcs|dmcs|g' Makefile.in
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}
@@ -41,6 +49,7 @@ package() {
# Install desktop and icon files
install -Dm644 Menu/$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
install -Dm644 Menu/$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ # Runtime work-around
+ sed -i "s|exec mono.*|exec mono \-\-runtime\=v4\.0 \"\/usr\/\$\{exec\_prefix\}\/lib\/gnome\-rdp\/gnome\-rdp\.exe\" \"\$\@\"|g" "$pkgdir/usr/bin/gnome-rdp"
}
-md5sums=('3c1329702914f8b1c213c0bb00d078cf'
- '7bbe98eadfe199c5664fd69a4531fb3d')