summaryrefslogtreecommitdiff
path: root/pcr/gnustep-gui/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gnustep-gui/PKGBUILD')
-rw-r--r--pcr/gnustep-gui/PKGBUILD108
1 files changed, 89 insertions, 19 deletions
diff --git a/pcr/gnustep-gui/PKGBUILD b/pcr/gnustep-gui/PKGBUILD
index bdccf2257..21a05663c 100644
--- a/pcr/gnustep-gui/PKGBUILD
+++ b/pcr/gnustep-gui/PKGBUILD
@@ -1,33 +1,100 @@
-# $Id$
-# Maintainer (AUR): Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Maintainer (AUR): Vesa Kaihlavirta <vegai@iki.fi>
-# Contributor (AUR): Sebastian Sareyko <public@nooms.de>
+# Maintainer (aur): <mumei AT airmail DOT cc>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Vesa Kaihlavirta <vegai@iki.fi>
+# Contributor: Sebastian Sareyko <public@nooms.de>
+# Maintainer: bill-auger <bill-auger@programmer.net>
+
+
+# build order: (gnustep-base) <- gnustep-gui <- gnustep-back <- gnustep-netclasses
-# parabola changes and rationale:
-# no changes.
pkgname=gnustep-gui
-pkgver=0.26.2
+pkgver=0.30.0
pkgrel=1
pkgdesc="The GNUstep GUI class library"
-arch=('x86_64' 'i686' 'armv7h')
-url="http://www.gnustep.org/"
+arch=(armv7h i686 x86_64)
+url=http://www.gnustep.org/
license=('LGPL')
-depends=('aspell' 'gcc-libs' 'libcups' 'audiofile' 'libsndfile' 'giflib' 'libao')
-makedepends=('gcc-objc' 'gnustep-base' 'gnustep-make')
-conflicts=('gnustep-gui-svn')
+depends=(
+ 'gcc-libs'
+ 'libjpeg'
+ 'libpng'
+ 'libtiff'
+)
+makedepends=(
+ 'gcc-objc'
+ 'gnustep-base'
+ 'gnustep-make'
+)
+makedepends=( ${makedepends[*]/gnustep-base/} ) # this is a run-time dependency
+optdepends=(
+ 'aspell'
+ 'audiofile'
+ 'flite1: required for speech synthesis'
+ 'giflib'
+ 'libao'
+ 'libcups'
+ 'libsndfile'
+)
+provides=('libgnustep-gui.so')
groups=('gnustep-core')
options=('!makeflags')
-source=(https://github.com/gnustep/libs-gui/releases/download/gui-${pkgver//./_}/gnustep-gui-${pkgver}.tar.gz)
-#{,.sig}) # Upstream Signature wasn't correctly created
-sha256sums=('09ab2ac10f4bf98f1254c6c525c752d1f7b13bf0e6cd95530452c504fae7b4db')
-# 'SKIP')
-#validpgpkeys=('83AAE47CE829A4146EF83420CA868D4C99149679')
+source=(https://github.com/gnustep/libs-gui/releases/download/gui-${pkgver//./_}/$pkgname-$pkgver.tar.gz{,.sig})
+sha256sums=('469dcaa54ed05b2520a704c30c0761a75b3ade8428e2e64645fb7b38a15c3cc3'
+ 'SKIP')
+validpgpkeys=('83AAE47CE829A4146EF83420CA868D4C99149679')
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
+
+_version_constraint() # (dep_pkgname [precision])
+{
+ Log() { [[ "${FUNCNAME[2]}" == package ]] && echo "$@" >&2 || : ; }
+
+
+ local dep_pkgname=$1
+ declare -i req_precision=$2
+ local full_version=$(pacman -S --print-format='%v' ${dep_pkgname} 2> /dev/null | tail -n 1)
+ local n_dots=$(tmp=${full_version%-*} ; tmp=${tmp//[^\.]} ; echo "${#tmp}" ;)
+ local def_precision=$(( n_dots + 1 ))
+ local is_prec_valid=$(( req_precision > 0 && req_precision <= def_precision ))
+ local precision=$((( is_prec_valid )) && echo ${req_precision} || echo ${def_precision})
+ local pkgver_rx='[0-9A-Za-z_]+'
+ pkgver_rx=$(sed 's|\]|\+]|' <<<${pkgver_rx}) # according to the wiki, '+' is not allowed,
+ # but some pkgver have it (eg: 5.15.10+kde+r130)
+ local subver_rx='\.'${pkgver_rx}
+ local pkgrel_rx='[0-9]+'
+ local garbage_rx='[^0-9].*'
+ local capture_rx=${pkgver_rx}
+ for (( n_dots=1 ; n_dots < precision ; ++n_dots )) ; do capture_rx+=${subver_rx} ; done ;
+ local version pkgrel has_dot_char version_min version_max constraint_string
+ declare -i subver subver_inc pkgrel_inc
+
+ if [[ "${full_version}" =~ ^(${capture_rx})(${subver_rx})*-(${pkgrel_rx}).*$ ]]
+ then version=${BASH_REMATCH[1]} # pkgver cut to the requested precision
+ #unused=${BASH_REMATCH[2]} # discarded pkgver segments
+ pkgrel=${BASH_REMATCH[3]} # pkgrel with non-numerics right-trimmed
+ has_dot_char=$([[ "${version}" =~ \. ]] ; echo $(( ! $? )) ; )
+ subver=$(sed "s|${garbage_rx}||" <<<${version##*.}) # right-trim from any non-numeric
+ version=$( (( has_dot_char )) && echo ${version%.*}.${subver} || echo ${subver} )
+ subver_inc=$(( subver + 1 ))
+ pkgrel_inc=$(( pkgrel + 1 ))
+ version_min=$( (( ! is_prec_valid )) && echo ${full_version%-*}-${pkgrel} || \
+ echo ${version} )
+ version_max=$( ( (( ! is_prec_valid )) && echo ${full_version%-*}-${pkgrel_inc} ) || \
+ ( [[ "${version}" =~ \. ]] && echo ${version%.*}.${subver_inc} ) || \
+ echo ${subver_inc} )
+ constraint_string="${dep_pkgname}>=${version_min} ${dep_pkgname}<${version_max}"
+
+ Log "Applied version constraint: '${constraint_string}'"
+ else Log "ERROR: in _version_constraint() parsing: dep_pkgname='${dep_pkgname}' full_version='${full_version}'"
+ exit 1
+ fi
+
+ unset -f Log
+
+ echo -n "${constraint_string}"
}
+
build() {
cd "$srcdir"/$pkgname-$pkgver
. /usr/share/GNUstep/Makefiles/GNUstep.sh
@@ -36,6 +103,9 @@ build() {
}
package() {
+ # pin to strongly-coupled dependency versions
+ depends+=( $(_version_constraint gnustep-base 2) )
+
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}