summaryrefslogtreecommitdiff
path: root/pcr/grass/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/grass/PKGBUILD')
-rw-r--r--pcr/grass/PKGBUILD62
1 files changed, 27 insertions, 35 deletions
diff --git a/pcr/grass/PKGBUILD b/pcr/grass/PKGBUILD
index 8043821a4..dcbd97b38 100644
--- a/pcr/grass/PKGBUILD
+++ b/pcr/grass/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer (Arch): Thomas Dziedzic < gostrc at gmail >
-# Contributor (Arch): dibblethewrecker dibblethewrecker.at.jiwe.dot.org
-# Contributor (Arch): Emiliano Vavassori <syntaxerrormmm(at)gmail.com>
+# Contributor (Arch) : Thomas Dziedzic < gostrc at gmail >
+# Contributor (Arch) : dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+# Contributor (Arch) : Emiliano Vavassori <syntaxerrormmm(at)gmail.com>
+# Maintainer (Parabola) :
pkgname=grass
-pkgver=6.4.2
-pkgrel=5
+pkgver=6.4.3
+pkgrel=3
pkgdesc='Geographic Information System (GIS) used for geospatial data management and analysis, image processing, graphics/maps production, spatial modeling, and visualization.'
arch=('i686' 'x86_64')
url='http://grass.osgeo.org/'
license=('GPL')
-depends=('cfitsio' 'fftw' 'gdal' 'glu' 'libjpeg' 'libpng' 'libtiff' 'libxmu' 'mesa' 'python2' 'postgresql' 'proj' 'tcl' 'tk' 'wxpython' 'xorg-server')
+depends=('cfitsio' 'fftw' 'gdal' 'glu' 'libjpeg' 'libpng' 'libtiff' 'libxmu' 'ncurses' 'mesa' 'python2' 'postgresql' 'proj' 'tcl' 'tk' 'wxpython2.8' 'xorg-server' 'zlib')
makedepends=('freetype2')
optdepends=('sqlite3: sqlite3 database interface'
'mysql: mysql database interface'
@@ -25,29 +26,31 @@ source=("http://grass.osgeo.org/grass64/source/${pkgname}-${pkgver}.tar.gz"
"grass.sh"
"grass.conf"
"grass-python2.patch"
- "grass-tk86-fix.patch")
-md5sums=('d3398d6b1e3a2ef19cfb6e39a5ae9919'
- '23da2e9399b3c5504851dec37821abe1'
- '6103480c2a1adc19a50b9e925e5e6d4c'
- '8717c73e7d262b1cff44d35ce80c50bb'
- 'b7cb69248a387f70dabd5ce20b8297dc')
+ "wxpython2.8-fix.patch")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # Replacing previous python2 fixes with a patch.
- # Thanks to Gunther Schulz to have reported a possible bug in the patching.
- patch -p1 -i "${srcdir}/grass-python2.patch"
-
- # Solves build issue reported here:
- # http://trac.osgeo.org/grass/ticket/1843
- patch -p1 -i "${srcdir}/grass-tk86-fix.patch"
+ # Fixing by hand shebang for .py files.
+ find . -iname \*.py | xargs sed -ie 's:^#!/usr/bin/env python$:#!/usr/bin/env python2:'
+ find . -iname \*.py | xargs sed -ie 's:^#!/usr/bin/python$:#!/usr/bin/env python2:'
+
+ # Fixing Makefile compilation
+ patch -p0 -i "${srcdir}/grass-python2.patch"
- # the following exports are probably not needed
+ # Fixing linking to wxpython 2.8 - Thanks to czk <msieczka(at)sieczka.org>
+ patch -p0 -i "${srcdir}/wxpython2.8-fix.patch"
+
+ # The following exports are probably not needed
export PYTHON=python2
export DOXNAME=python2
export GRASS_python=python2
+ # Trying to fix a problem with GRASS configure
+ # Thanks to Scimmia from ArchLinux Forum
+ # https://bbs.archlinux.org/viewtopic.php?id=161172
+ unset CPPFLAGS
+
# Enabling 64bit support - EGV
if [ "$CARCH" = "x86_64" ]; then
ENABLE64BIT="--enable-64bit"
@@ -57,10 +60,11 @@ build() {
# see ${srcdir}/grass-6.4.0/REQUIREMENTS.html for options
# GLw is hard disabled, since no package in Archlinux can provide it - EGV
+ # Fixing dependency on wxpython2.8 in configure. - EGV
./configure ${ENABLE64BIT} \
--prefix=/opt \
- --enable-64bit \
--enable-W11 \
+ --without-glw \
--with-jpeg \
--with-tiff \
--with-png \
@@ -70,7 +74,6 @@ build() {
--with-postgres \
--with-freetype \
--with-freetype-includes=/usr/include/freetype2 \
- --without-glw \
--with-nls \
--with-gdal \
--with-geos \
@@ -78,14 +81,14 @@ build() {
--with-proj-libs=/usr/lib \
--with-proj-share=/usr/share/proj \
--with-python=/usr/bin/python2-config \
- --with-wxwidgets=/usr/bin/wx-config
+ --with-wxwidgets=/usr/lib/wx/config/gtk2-unicode-release-2.8
# sqlite3 support
# --with-sqlite \
# mysql support
# --with-mysql \
- # --with-mysql-includes=/usr/include/mysql \
+ # --with-mysql-includes=/usr/include/mariadb \
# blas support
# --with-blas \
@@ -94,11 +97,6 @@ build() {
# --with-lapack \
make
-
- # some more potential problems nvm, works without, but save for future use if problems arrise
- #cd ${pkgdir}/opt/grass-${pkgver}
- #sed -i 's/PYTHON = python/PYTHON = python2/' include/Make/Python.make
- #sed -i 's/GRASS_PYTHON=python/GRASS_PYTHON=python2/' etc/Init.sh
}
package() {
@@ -129,10 +127,4 @@ package() {
install -D -m644 ${srcdir}/grass.conf \
${pkgdir}/etc/ld.so.conf.d/grass.conf
-
- # install g.html2man which is needed for some extensions
- # FS#25705 - [grass] g.html2man is not installed into package directory
- # https://bugs.archlinux.org/task/25705
- # most likely upstream problem which will be fixed in a version later than 6.4.1
- cp -r ./tools/g.html2man ${pkgdir}/opt/${pkgname}-${pkgver}/tools
}