summaryrefslogtreecommitdiff
path: root/pcr/guile-bytestructures/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/guile-bytestructures/PKGBUILD')
-rw-r--r--pcr/guile-bytestructures/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/pcr/guile-bytestructures/PKGBUILD b/pcr/guile-bytestructures/PKGBUILD
new file mode 100644
index 000000000..1547baaec
--- /dev/null
+++ b/pcr/guile-bytestructures/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer (aur): Jelle van der Waa <jelle@archlinux.org>
+# Contributor (aur): lantw44 (at) gmail (dot) com
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+# parabola changes and rationale:
+# - Add armv7h and i686 architectures support.
+
+pkgname=guile-bytestructures
+_pkgname=bytestructures
+pkgver=1.0.10
+pkgrel=1
+pkgdesc='Structured access library to bytevector contents for Guile'
+arch=('armv7h' 'i686' 'x86_64')
+url="https://github.com/TaylanUB/scheme-bytestructures"
+license=('GPL3')
+depends=('guile')
+makedepends=('git')
+source=("https://github.com/TaylanUB/scheme-${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('bb8a78c1e570f90e344368196844ee0f143682b3d4c6ab69d6de0fa0d7b7c20d')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}