summaryrefslogtreecommitdiff
path: root/pcr/guile-json/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/guile-json/PKGBUILD')
-rw-r--r--pcr/guile-json/PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/pcr/guile-json/PKGBUILD b/pcr/guile-json/PKGBUILD
index 1d3e45dfc..116c1aaf7 100644
--- a/pcr/guile-json/PKGBUILD
+++ b/pcr/guile-json/PKGBUILD
@@ -1,18 +1,22 @@
-# Maintainer (AUR): holos
-# Contributor (AUR): tantalum
+# Maintainer (aur): Ting-Wei Lan <lantw44 at gmail dot com>
+# Contributor (aur): Thomas Koller-Cherek <tk120 at protonmail dot com>
+# Contributor (aur): holos
+# Contributor (aur): tantalum
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
# parabola changes and rationale:
# no changes.
pkgname=guile-json
+pkgver=4.7.3
pkgrel=1
-pkgver=3.1.0
pkgdesc='JSON module for Guile'
-url="https://github.com/aconchillo/guile-json"
-arch=('any')
-license=('LGPL')
-source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('e303d0db3f34ac515b8f61db8ed35be8b6c5014d7ab4a5a8ef9b44723ed3d8f9')
+arch=('x86_64' 'i686' 'armv7h')
+url='https://savannah.nongnu.org/projects/guile-json'
+license=('GPL3')
+depends=('guile')
+source=("https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('38ba048ed29d12f05b32c5b2fb7a51795c448b41e403a2b1b72ff0035817f388')
build() {
cd "$pkgname-$pkgver"
@@ -20,6 +24,11 @@ build() {
make
}
+check(){
+ cd "$pkgname-$pkgver"
+ make check
+}
+
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install