summaryrefslogtreecommitdiff
path: root/pcr/guile-quickcheck/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/guile-quickcheck/PKGBUILD')
-rw-r--r--pcr/guile-quickcheck/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/pcr/guile-quickcheck/PKGBUILD b/pcr/guile-quickcheck/PKGBUILD
new file mode 100644
index 000000000..ba5567bfd
--- /dev/null
+++ b/pcr/guile-quickcheck/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer (aur): lantw44 (at) gmail (dot) com
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+# parabola changes and rationale:
+# no changes.
+
+pkgname=guile-quickcheck
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Randomized property-based testing for Guile'
+arch=('x86_64' 'i686' 'armv7h')
+url='https://ngyro.com/software/guile-quickcheck.html'
+license=('GPL3')
+depends=('guile')
+source=("https://files.ngyro.com/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('cb99ac5be99b43b61eb9c452d953543e890e2a83fc83acac289d94316888bc0e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}