summaryrefslogtreecommitdiff
path: root/pcr/kiwix-lib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/kiwix-lib/PKGBUILD')
-rw-r--r--pcr/kiwix-lib/PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/pcr/kiwix-lib/PKGBUILD b/pcr/kiwix-lib/PKGBUILD
index 20012249a..30aababe2 100644
--- a/pcr/kiwix-lib/PKGBUILD
+++ b/pcr/kiwix-lib/PKGBUILD
@@ -4,16 +4,16 @@
# - No changes
pkgname=kiwix-lib
-pkgver=8.2.2
+pkgver=9.4.0
pkgrel=1
pkgdesc="Library providing the Kiwix software core"
license=('GPL3')
arch=('armv7h' 'i686' 'x86_64')
-depends=('libzim' 'pugixml' 'mustache=3.2.1' 'xapian-core' 'aria2' 'libmicrohttpd')
+depends=('libzim>=6.1.1' 'pugixml' 'mustache' 'xapian-core' 'aria2' 'libmicrohttpd')
makedepends=('meson' 'gtest')
url='https://github.com/kiwix/kiwix-lib'
-source=("https://github.com/kiwix/kiwix-lib/archive/${pkgver}.tar.gz")
-sha256sums=(dc8d454d79b175c0b9f3c4d268db17da8e80fcd8df3987af0f58cb399bd5da61)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=(ccc883d06f111ebcb7f3530299798501b97400f319814871e17f73fa3e349766)
build() {
cd "${pkgname}-${pkgver}"
@@ -28,6 +28,7 @@ check() {
}
package() {
+ install -Dm644 "${pkgname}-${pkgver}/COPYING" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
cd "${pkgname}-${pkgver}/build"
DESTDIR="${pkgdir}" ninja install
}