summaryrefslogtreecommitdiff
path: root/pcr/minicomputer/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/minicomputer/PKGBUILD')
-rw-r--r--pcr/minicomputer/PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/pcr/minicomputer/PKGBUILD b/pcr/minicomputer/PKGBUILD
index ff9bcf5dd..42b9c75ab 100644
--- a/pcr/minicomputer/PKGBUILD
+++ b/pcr/minicomputer/PKGBUILD
@@ -1,13 +1,15 @@
-# Maintainer (Arch): speps <speps at aur dot archlinux dot org>
-# Contributor (Arch): farid abdelnour <farid at archlinux-br.org>
-# Contributor (Arch): DonVla <donvla@users.sourceforge.net>
+# Maintainer (arch): speps <speps at aur dot archlinux dot org>
+# Contributor: farid abdelnour <farid at archlinux-br.org>
+# Contributor: DonVla <donvla@users.sourceforge.net>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
pkgname=minicomputer
pkgver=1.41
-pkgrel=3
-pkgdesc="A standalone Linux softwaresynthesizer for creating experimental electronic sounds."
-arch=('i686' 'x86_64')
+pkgrel=4
+pkgdesc="Software synthesizer for creating experimental electronic sounds"
+arch=('i686' 'x86_64') # no arm - requires SSE
url="http://minicomputer.sourceforge.net"
license=('GPL3')
depends=('fltk' 'jack' 'liblo')
@@ -15,18 +17,24 @@ makedepends=('scons')
install="$pkgname.install"
source=("http://downloads.sourceforge.net/sourceforge/$pkgname/MinicomputerV$pkgver.tar.gz"
"$pkgname.desktop")
+source+=(print.patch)
md5sums=('d2524f5fee7475159292e29a5bcd73d2'
'3cc74321d55870b1684767255c74c2f8')
+md5sums+=('ed8548394b3dcf1823c047fd7e9fcf9e')
+
prepare() {
# installpresets.sh fix
sed -i "s|factory|/usr/share/$pkgname/&|g" installpresets.sh
# DSO linking fix
- sed -i "35aenv.Append(LINKFLAGS = ['-lm'])" -i SConstruct
+ sed -i "35aenv.Append(LIBS = ['m'])" -i SConstruct
# missing includes
sed -i '30a#include <unistd.h>' editor/Memory.h
+
+ # fix 'print' commands in scons file
+ patch -Np1 < print.patch
}
build() {
@@ -58,5 +66,3 @@ package() {
install -Dm755 installpresets.sh \
"$pkgdir/usr/share/$pkgname/installpresets.sh"
}
-
-# vim:set ts=2 sw=2 et: