summaryrefslogtreecommitdiff
path: root/pcr/ocsync/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/ocsync/PKGBUILD')
-rw-r--r--pcr/ocsync/PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/pcr/ocsync/PKGBUILD b/pcr/ocsync/PKGBUILD
index 34ce2f62c..97bc26754 100644
--- a/pcr/ocsync/PKGBUILD
+++ b/pcr/ocsync/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Kuba Serafinowski <zizzfizzix(at)gmail(dot)com>
# https://github.com/zizzfizzix/pkgbuilds
-
+# Maintainer: Jorge Araya Navarro <jorgean@lavabit.com>
+#
##############################################################
#### The section below can be adjusted to suit your needs ####
##############################################################
@@ -14,28 +15,31 @@ _buildtype="Release"
##############################################################
pkgname=ocsync
-pkgver=0.70.5
-pkgrel=1
-pkgdesc="A file synchronizer especially designed for you, the normal user."
+pkgver=0.80.0
+pkgrel=3
+pkgdesc="A file synchronizer especially designed for you, the normal user. Dependency of owncloud-client."
arch=("i686" "x86_64")
url="http://www.csync.org"
license=('GPL2')
-depends=('sqlite3' 'iniparser' 'neon' 'smbclient' 'libssh')
+depends=('sqlite3' 'iniparser' 'neon')
makedepends=('cmake')
-#optdepends=('samba: smb support' 'libssh: sftp support')
+optdepends=('libssh: sftp support')
provides=('csync' 'csync-owncloud')
conflicts=('csync' 'csync-owncloud')
+backup=('etc/ocsync/ocsync.conf' 'etc/ocsync/ocsync_exclude.conf')
source=("http://download.owncloud.com/download/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('7c8b6f260cc53d29c4355f6837990329')
+md5sums=('db46cdb4c710a607dfc062ed0a413b35')
-# Clean options array to strip pkg if release buildtype is chosen
-if [[ ${_buildtype} == "Release" ]] || [[ ${_buildtype} == "release" ]]; then
- options=()
+if [[ ! ${_buildtype} == "Release" ]] && [[ ! ${_buildtype} == "release" ]]; then
+ options=(!strip)
fi
-build() {
+prepare() {
if [[ -e ${srcdir}/${pkgname}-${pkgver}-build ]]; then rm -rf ${srcdir}/${pkgname}-${pkgver}-build; fi
mkdir ${srcdir}/${pkgname}-${pkgver}-build
+}
+
+build() {
cd ${srcdir}/${pkgname}-${pkgver}-build
cmake -DCMAKE_BUILD_TYPE=${_buildtype} \