summaryrefslogtreecommitdiff
path: root/pcr/owncloud-client/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/owncloud-client/PKGBUILD')
-rw-r--r--pcr/owncloud-client/PKGBUILD27
1 files changed, 14 insertions, 13 deletions
diff --git a/pcr/owncloud-client/PKGBUILD b/pcr/owncloud-client/PKGBUILD
index 69905f40a..a4e86099b 100644
--- a/pcr/owncloud-client/PKGBUILD
+++ b/pcr/owncloud-client/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Kuba Serafinowski <zizzfizzix(at)gmail(dot)com>
# https://github.com/zizzfizzix/pkgbuilds
-
+# Maintainer: Jorge Araya Navarro <jorgean@lavabit.com>
+#
##############################################################
#### The section below can be adjusted to suit your needs ####
##############################################################
@@ -15,31 +16,32 @@ _buildtype="Release"
_name=mirall
pkgname=owncloud-client
-pkgver=1.2.3
-pkgrel=1
+pkgver=1.3.0
+pkgrel=2
pkgdesc="ownCloud client based on mirall"
arch=('i686' 'x86_64')
url="http://owncloud.org/"
license=('GPL2')
depends=('qt4' 'ocsync')
makedepends=('cmake')
+optdepends=('qtkeychain: safe password storage')
provides=('mirall' 'owncloud-client')
conflicts=('mirall-git')
install=owncloud-client.install
backup=('etc/owncloud-client/sync-exclude.lst')
-source=("http://download.owncloud.com/download/${_name}-${pkgver}.tar.bz2"
- "${pkgname}.desktop")
-md5sums=('a3aa2cb1b9ccb13c7e8b0ef8a1b539df'
- 'e223d162626c2ff54efebaa90a182d81')
-
-# Clean options array to strip pkg if release buildtype is chosen
-if [[ ${_buildtype} == "Release" ]] || [[ ${_buildtype} == "release" ]]; then
- options=()
+source=("http://download.owncloud.com/download/${_name}-${pkgver}.tar.bz2")
+md5sums=('ee2e7bafc714399f2027fefed853f968')
+
+if [[ ! ${_buildtype} == "Release" ]] && [[ ! ${_buildtype} == "release" ]]; then
+ options=(!strip)
fi
-build() {
+prepare() {
if [[ -e ${srcdir}/${_name}-${pkgver}-build ]]; then rm -rf ${srcdir}/${_name}-${pkgver}-build; fi
mkdir ${srcdir}/${_name}-${pkgver}-build
+}
+
+build() {
cd ${srcdir}/${_name}-${pkgver}-build
cmake -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
@@ -55,5 +57,4 @@ build() {
package() {
cd ${srcdir}/${_name}-${pkgver}-build
make DESTDIR=${pkgdir} install
- install -Dm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
}