summaryrefslogtreecommitdiff
path: root/pcr/pciutils-staticlibs/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/pciutils-staticlibs/PKGBUILD')
-rw-r--r--pcr/pciutils-staticlibs/PKGBUILD44
1 files changed, 28 insertions, 16 deletions
diff --git a/pcr/pciutils-staticlibs/PKGBUILD b/pcr/pciutils-staticlibs/PKGBUILD
index 5b52f41e1..d64807d7a 100644
--- a/pcr/pciutils-staticlibs/PKGBUILD
+++ b/pcr/pciutils-staticlibs/PKGBUILD
@@ -1,28 +1,38 @@
-# $Id$
-# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
-# Maintainer (Arch pcutils): Tobias Powalowski <tpowa@archlinux.org>
+# Maintainer (arch): Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Luke Shumaker <lukeshu@parabola.nu>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
+
pkgname=pciutils
-pkgver=3.3.0
-pkgrel=1
+pkgver=3.7.0
+pkgrel=2
pkgdesc="PCI bus configuration space access library and tools"
-arch=(i686 x86_64)
+arch=(x86_64)
+arch+=(i686)
license=('GPL2')
-#groups=('base')
-url="http://mj.ucw.cz/sw/pciutils/"
-depends=('glibc' 'hwids' 'kmod')
+url="https://mj.ucw.cz/sw/pciutils/"
+depends=('glibc' 'hwdata' 'kmod')
+#makedepends=('git') # FIXME: declared, but unused upstream ('pciutils')
source=(#ftp://ftp.kernel.org/pub/software/utils/${pkgname}/${pkgname}-${pkgver}.tar.bz2
- ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${pkgname}-${pkgver}.tar.gz)
-md5sums=('b73bca5b1c2fd20a17a19f5040411521')
+ https://mj.ucw.cz/download/linux/pci/${pkgname}-${pkgver}.tar.gz{,.sign})
+ #git+https://github.com/pciutils/pciutils.git#tag=v$pkgver?signed)
+validpgpkeys=(
+ '5558F9399CD7836850553C6EC28E7847ED70F82D' # Martin Mares <mj@ucw.cz>
+ )
+
+md5sums=('51554c538b5a57b61123326e14ea28a1'
+ 'SKIP')
options=(staticlibs)
_pkgname=$pkgname
pkgname+='-staticlibs'
-pkgdesc+=" (build with options=(staticlibs))"
+pkgdesc+=" (static libs)"
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
+
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd $_pkgname-$pkgver
make OPT="${CFLAGS} -fPIC -DPIC" ZLIB=no SHARED=no PREFIX=/usr SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man SBINDIR=/usr/bin lib/libpci.a
cp lib/libpci.a "${srcdir}/"
make clean
@@ -30,9 +40,11 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd $_pkgname-$pkgver
make SHARED=yes PREFIX=/usr SBINDIR=/usr/bin SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man DESTDIR="${pkgdir}" install install-lib
+ # this is now supplied by the 'hwdata' package
+ rm -rf "$pkgdir"/usr/{sbin/update-pciids,share/{man/man8/update-pciids.8,hwdata}}
+
+ # install the static lib
install -m644 "${srcdir}/libpci.a" "${pkgdir}/usr/lib/"
- # this is now supplied by the hwids package
- rm -rf $pkgdir/usr/{sbin/update-pciids,share/{man/man8/update-pciids.8,hwdata}}
}