summaryrefslogtreecommitdiff
path: root/pcr/perl-php-serialization/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/perl-php-serialization/PKGBUILD')
-rw-r--r--pcr/perl-php-serialization/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/pcr/perl-php-serialization/PKGBUILD b/pcr/perl-php-serialization/PKGBUILD
index f09269c92..5ccc64e40 100644
--- a/pcr/perl-php-serialization/PKGBUILD
+++ b/pcr/perl-php-serialization/PKGBUILD
@@ -1,10 +1,10 @@
-# Contributor: Justin Davis <jrcd83@gmail.com>
-# Generator : CPANPLUS::Dist::Arch 1.18
-# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
+# CPAN Name : PHP-Serialization
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
pkgname='perl-php-serialization'
pkgver='0.34'
-pkgrel='1'
+pkgrel='2'
pkgdesc="simple flexible means of converting the output of PHP's serialize() into the equivalent Perl memory structure, and vice versa."
arch=('any')
license=('PerlArtistic' 'GPL')
@@ -15,7 +15,7 @@ url='http://search.cpan.org/dist/PHP-Serialization'
source=('http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/PHP-Serialization-0.34.tar.gz')
md5sums=('333af0848ad79931875a35cc61dc22e0')
sha512sums=('72218973f21ab71419751cf818e6bd998235aa74bf8ae60ec4a6080ba169d0d7fcefde4f433ce3f6f30ed3084a651deb8aa3a5dd818fc6ebf3fb6188def4efe7')
-_distdir="${srcdir}/PHP-Serialization-0.34"
+_distdir="PHP-Serialization-0.34"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -24,22 +24,23 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
make install
+
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}