summaryrefslogtreecommitdiff
path: root/pcr/perl-sys-mmap/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/perl-sys-mmap/PKGBUILD')
-rw-r--r--pcr/perl-sys-mmap/PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/pcr/perl-sys-mmap/PKGBUILD b/pcr/perl-sys-mmap/PKGBUILD
index e563d5da7..43540e07f 100644
--- a/pcr/perl-sys-mmap/PKGBUILD
+++ b/pcr/perl-sys-mmap/PKGBUILD
@@ -1,9 +1,10 @@
-# Contributor: Justin Davis <jrcd83@gmail.com>
-# Generator : CPANPLUS::Dist::Arch 1.18
+# CPAN Name : Sys-Mmap
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
pkgname='perl-sys-mmap'
pkgver='0.16'
-pkgrel='1'
+pkgrel='3'
pkgdesc="uses mmap to map in a file as a Perl variable"
arch=('i686' 'x86_64')
license=('PerlArtistic' 'GPL')
@@ -14,7 +15,7 @@ url='http://search.cpan.org/dist/Sys-Mmap'
source=('http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/Sys-Mmap-0.16.tar.gz')
md5sums=('faae869e876fa86f92e6de3f13af3aef')
sha512sums=('9f533f8eaa2707a77fa69dc0163e5e55b13d6653ddb5f7850c3fcaa090c79069cccedb947c1b8cd5a125fd7b055803eff437697c120785f422bff0414be7cd05')
-_distdir="${srcdir}/Sys-Mmap-0.16"
+_distdir="Sys-Mmap-0.16"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,22 +24,23 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$_distdir"
+ cd "$srcdir/$_distdir"
make install
+
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}