summaryrefslogtreecommitdiff
path: root/pcr/pgl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/pgl/PKGBUILD')
-rw-r--r--pcr/pgl/PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/pcr/pgl/PKGBUILD b/pcr/pgl/PKGBUILD
index 6b2191321..42c84f593 100644
--- a/pcr/pgl/PKGBUILD
+++ b/pcr/pgl/PKGBUILD
@@ -2,30 +2,30 @@
# Contributor (Arch): Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname=pgl
-pkgver=2.3.0
-pkgrel=2
+pkgver=2.3.1
+pkgrel=1
pkgdesc='A privacy oriented firewall application (GUI).'
arch=('i686' 'x86_64')
url='http://sourceforge.net/projects/peerguardian/'
license=('GPL3')
-depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt4' 'polkit-qt4' 'whois' 'gksu')
+depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt4' 'whois')
optdepends=('unzip: for zipped blocklists'
- 'p7zip: for 7z blocklists'
- 'net-tools: to whitelist local IP addresses'
- 'networkmanager: to whitelist newly started network interfaces'
- 'smtp-forwarder: to send reports'
- 'tcptraceroute: to diagnose connection problems')
+ 'p7zip: for 7z blocklists'
+ 'net-tools: to whitelist local IP addresses'
+ 'networkmanager: to whitelist newly started network interfaces'
+ 'smtp-forwarder: to send reports'
+ 'tcptraceroute: to diagnose connection problems')
makedepends=('zlib')
conflicts=('pgl-cli' 'pgl-git')
backup=('etc/pgl/allow.p2p'
- 'etc/pgl/blocklists.list'
- 'etc/pgl/pglcmd.conf'
- 'etc/logrotate.d/pglcmd'
- 'etc/logrotate.d/pgld')
+ 'etc/pgl/blocklists.list'
+ 'etc/pgl/pglcmd.conf'
+ 'etc/logrotate.d/pglcmd'
+ 'etc/logrotate.d/pgld')
install=install
changelog=changelog
source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz")
-sha512sums=('535f13d6b17bbea099e415e9dd463ebf4e2ffa9af4d8ae96c7ace2667c84380f506018aca2b6b6a6d4ca1e2afd24fc6eaf9544eb00710645d562f2aa1fa5a1a7')
+sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520')
build() {
cd "$pkgname-$pkgver"
@@ -48,4 +48,4 @@ package() {
# integrates daemon log in systemd journal
sed -i '/^LOG_SYSLOG/s/0/1/g' $pkgdir/usr/lib/pgl/pglcmd.defaults
-}
+} \ No newline at end of file