summaryrefslogtreecommitdiff
path: root/pcr/pjproject/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/pjproject/PKGBUILD')
-rw-r--r--pcr/pjproject/PKGBUILD55
1 files changed, 29 insertions, 26 deletions
diff --git a/pcr/pjproject/PKGBUILD b/pcr/pjproject/PKGBUILD
index cfdaeb0e8..001c6ae7c 100644
--- a/pcr/pjproject/PKGBUILD
+++ b/pcr/pjproject/PKGBUILD
@@ -1,42 +1,45 @@
-# Maintainer (AUR): Xavier Devlamynck <magicrhesus@ouranos.be>
+# Maintainer (AUR): Caleb Maclennan <caleb@alerque.com>
+# Contributor (AUR): Xavier Devlamynck <magicrhesus@ouranos.be>
# Contributor (AUR): Marti Raudsepp <marti@juffo.org>
-#Contributor (AUR): Travis Hegner <travis.hegner@gmail.com>
+# Contributor (AUR): Travis Hegner <travis.hegner@gmail.com>
+# Contributor (Parabola): Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
# parabola changes and rationale:
-# fixing misdetection of x86 intrinsics on armv7h
+# - don't autodetect x86 extensions at compile time (-march=native)
+# as it would break on machines that don't have the all the extensions
+# that the build machine has
+# - added --disable-libwebrtc not to require sse2 (parabola minimum system
+# requirements require an i686 compatible machine, and the P6 architecture
+# only has sse and MMX, and not sse2)
pkgname=pjproject
-pkgver=2.7.1
+pkgver=2.8
pkgrel=1
-pkgdesc="Open source SIP stack and media stack"
+pkgdesc='Open source SIP stack and media stack'
arch=('i686' 'x86_64' 'armv7h')
-url="http://www.pjsip.org/"
+url='http://www.pjsip.org/'
license=('GPL')
depends=('openssl' 'portaudio' 'speex' 'alsa-lib' 'libsamplerate' 'util-linux' 'ffmpeg' 'libsrtp' 'opus')
makedepends=('e2fsprogs' 'python')
-install=pjproject.install
-source=(http://www.pjsip.org/release/${pkgver}/pjproject-${pkgver}.tar.bz2
- arm-build.patch)
-sha256sums=('59fabc62a02b2b80857297cfb10e2c68c473f4a0acc6e848cfefe8421f2c3126'
- 'fc6ccc004586e504d89fd14bbe2c26747849b1b9b617f4427e593de6a1c6b3db')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 < "${srcdir}/arm-build.patch"
-}
+optdepends=('alsa-lib' 'e2fsprogs' 'python')
+source=("http://www.pjsip.org/release/$pkgver/$pkgname-$pkgver.tar.bz2")
+sha256sums=('503d0bd7f9f13dc1492ac9b71b761b1089851fbb608b9a13996edc3c42006f79')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- export CXXFLAGS="${CXXFLAGS} -fPIC -march=native"
- export CFLAGS="${CXXFLAGS} -DNDEBUG"
- ./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound
- echo "#define PJ_HAS_IPV6 1" >> "${srcdir}/${pkgname}-${pkgver}/pjlib/include/pj/config_site.h"
- make -j1 dep
- make -j1
+ cd "$pkgname-$pkgver"
+ export CXXFLAGS="$CXXFLAGS -fPIC"
+ if [ "$CARCH" = "i686" ]; then
+ export CXXFLAGS="$CXXFLAGS -march=i686"
+ fi
+ export CFLAGS="$CXXFLAGS -DNDEBUG"
+ ./configure --prefix=/usr --with-external-speex --with-external-srtp --with-external-pa --with-external-gsm --disable-oss --enable-shared --disable-opencore-amr --disable-v4l2 --disable-video --disable-sound --disable-libwebrtc
+ echo "#define PJ_HAS_IPV6 1" >> "$srcdir/$pkgname-$pkgver/pjlib/include/pj/config_site.h"
+ make -j1 dep
+ make -j1
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make -j1 DESTDIR=${pkgdir} install
- install -D -m755 pjsip-apps/bin/pjsua-* ${pkgdir}/usr/bin/pjsua
+ cd "$pkgname-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install
+ install -D -m755 pjsip-apps/bin/pjsua-*gnu* "$pkgdir"/usr/bin/pjsua
}