summaryrefslogtreecommitdiff
path: root/pcr/prosody-modules/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/prosody-modules/PKGBUILD')
-rw-r--r--pcr/prosody-modules/PKGBUILD78
1 files changed, 64 insertions, 14 deletions
diff --git a/pcr/prosody-modules/PKGBUILD b/pcr/prosody-modules/PKGBUILD
index adc15cfeb..dd41729b7 100644
--- a/pcr/prosody-modules/PKGBUILD
+++ b/pcr/prosody-modules/PKGBUILD
@@ -52,20 +52,70 @@ sha1sums=('SKIP')
mksource() {
cd "${srcdir}/${pkgname}-${pkgver}/"
# Clean up mercurial files.
- # Remove broken, unmaintained and unlicensed modules:
- # Note that only mod_admin_web seems to downloand nonfree dependencies through a script, and needs better inspection.
- # The rest are unlicensed, unmaintained or invasive to user privacy.
- local nonfree_files=( \.hg \.hgtags mod_admin_web mod_auth_external_insecure mod_bookmarks mod_captcha_registrations mod_compression_unsafe mod_couchdb mod_easy_invite mod_graceful_shutdown mod_pubsub_feeds mod_s2s_auth_monkeysphere mod_twitter mod_aws_profile mod_conversejs mod_pubsub_github mod_pubsub_twitter mod_s2s_auth_posh mod_sentry mod_slack_webhooks mod_sms_free mod_sms_clickatel mod_tweet_data )
- for nonfree_file in "${nonfree_files[@]}"
- do if [[ -d ${nonfree_file} || -f ${nonfree_file} ]]
- then
- echo "deleting ${nonfree_file}"
- rm -rf ${nonfree_file}
- else
- echo "cannot delete '${nonfree_file}' - mksource() needs re-working"
- return 1
- fi
- done
+ rm -rf \.hg \.hgtags
+
+ # Seems to download external dependencies, needs inspection.
+ rm -rf mod_admin_web
+
+ # Unmaintained and shouldn't be used.
+ rm -rf mod_auth_external_insecure
+
+ # Connects to AWS.
+ rm -rf mod_aws_profile
+
+ # Depricated, might conflict with built-in module.
+ rm -rf mod_bookmarks
+
+ # Requires modification to prosody core.
+ rm -rf mod_captcha_registrations
+
+ # Unsafe and unmaintained.
+ rm -rf mod_compression_unsafe
+
+ # Relies on conversejs' CDN, free software though.
+ rm -rf mod_conversejs
+
+ # Seems abandoned.
+ rm -rf mod_couchdb
+
+ # Deprecated.
+ rm -rf mod_easy_invite
+
+ # Integrated into core prosody software.
+ rm -rf mod_graceful_shutdown
+
+ # Seems to include unlicensed code.
+ rm -rf mod_pubsub_feeds
+
+ # Relies on github network services.
+ rm -rf mod_pubsub_github
+
+ # relies on twitter network services and API.
+ rm -rf mod_pubsub_twitter
+
+ # Monkeysphere project seems to be defunct.
+ rm -rf mod_s2s_auth_monkeysphere
+
+ # Relies on nonfree network services.
+ rm -rf mod_s2s_auth_posh
+
+ # Relies on nonfree network services.
+ rm -rf mod_sentry
+
+ # relies on nonfree network services.
+ rm -rf mod_slack_webhooks
+
+ # Relies on nonfree network services.
+ rm -rf mod_sms_clickatel
+
+ # Relies on nonfree network services.
+ rm -rf mod_sms_free
+
+ # Relies on nonfree network services.
+ rm -rf mod_tweet_data
+
+ # Relies on nonfree network services and unfinished/unmaintained.
+ rm -rf mod_twitter
}
package() {