summaryrefslogtreecommitdiff
path: root/pcr/python-efl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python-efl/PKGBUILD')
-rw-r--r--pcr/python-efl/PKGBUILD45
1 files changed, 22 insertions, 23 deletions
diff --git a/pcr/python-efl/PKGBUILD b/pcr/python-efl/PKGBUILD
index ddc7b5fe3..631ef72a8 100644
--- a/pcr/python-efl/PKGBUILD
+++ b/pcr/python-efl/PKGBUILD
@@ -1,38 +1,37 @@
-# Maintainer (AUR): Doug Newgard <scimmia at archlinux dot info>
+# Maintainer (aur): Doug Newgard <scimmia at archlinux dot info>
# Mantainer (AUR): Lorenzo Ferrillo <lorenzofersteam at live dot it>
+# Maintainer (aur): Philippe Bourjac <philippe dot bourjac at gmail dot com>
# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
# parabola changes and rationale:
-# - created split package for both python2 and python3
# - fixed license array (does not contain any GPL3 licensed code)
# - added missing makedepends: mesa libdrm
-pkgbase=python-efl
-pkgname=(python-efl python2-efl)
-pkgver=1.20.0
-pkgrel=2
-arch=('i686' 'x86_64' 'armv7h')
+_python=python
+_pkgname=python-efl
+pkgname=$_python-efl
+pkgver=1.25.0
+pkgrel=1
+pkgdesc="${_python^} bindings for the Enlightenment Foundation Libraries"
+arch=('i686' 'x86_64')
+arch+=( 'armv7h')
url="http://www.enlightenment.org"
license=('LGPL3')
-makedepends=("efl>=$pkgver" python-dbus python2-dbus mesa libdrm)
-source=("http://download.enlightenment.org/rel/bindings/python/$pkgbase-$pkgver.tar.xz")
-sha256sums=('70de0ee3fabe1e91da5aa0ca09dd908b62dbbeb5fce86ec194b8793967c30ea3')
+depends=("efl>=$pkgver" "dbus-python")
+makedepends=(mesa libdrm)
+source=("http://download.enlightenment.org/rel/bindings/python/$_pkgname-$pkgver.tar.xz")
+sha256sums=('99e06df773647acfb8e04786d6958bee5b8deae41d996ccaa68d7cca7b30612e')
#sha256sums=('SKIP')
+build() {
+ cd $_pkgname-$pkgver
-package_python-efl() {
- pkgdesc="Python bindings for the Enlightenment Foundation Libraries"
- depends=("efl>=$pkgver" "python-dbus")
- cd "$srcdir/$pkgbase-$pkgver"
- rm -rf build
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS README ChangeLog
+ $_python setup.py build
}
-package_python2-efl() {
- pkgdesc="Python2 bindings for the Enlightenment Foundation Libraries"
- depends=("efl>=$pkgver" "python2-dbus")
- cd "$srcdir/$pkgbase-$pkgver"
- rm -rf build
- python2 setup.py install --root="$pkgdir" --optimize=1
+package() {
+ cd $_pkgname-$pkgver
+
+ $_python setup.py install --root="$pkgdir" --optimize=1
+
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS README ChangeLog
}