summaryrefslogtreecommitdiff
path: root/pcr/python-humblewx/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python-humblewx/PKGBUILD')
-rw-r--r--pcr/python-humblewx/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/pcr/python-humblewx/PKGBUILD b/pcr/python-humblewx/PKGBUILD
new file mode 100644
index 000000000..ed1528cb8
--- /dev/null
+++ b/pcr/python-humblewx/PKGBUILD
@@ -0,0 +1,23 @@
+#Maintainer (AUR): Thibaud Kehler <thibaud.kehler at gmx dot net>
+pkgname='python-humblewx'
+_module='humblewx'
+pkgver='0.2.2'
+pkgrel=1
+pkgdesc="Library that simplifies creating user interfaces with wxPython."
+license=('GPL3')
+url="https://github.com/thetimelineproj/humblewx"
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/h/${_module}/${_module}-${pkgver}.tar.gz")
+sha256sums=('b327e6c8ed4c278136e0d15f436275f4f07f42f062d023e5ea999e7401bf9177')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}