summaryrefslogtreecommitdiff
path: root/pcr/python2-potr/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python2-potr/PKGBUILD')
-rw-r--r--pcr/python2-potr/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/pcr/python2-potr/PKGBUILD b/pcr/python2-potr/PKGBUILD
index 39613ad95..684912283 100644
--- a/pcr/python2-potr/PKGBUILD
+++ b/pcr/python2-potr/PKGBUILD
@@ -1,28 +1,34 @@
-# Maintainer: Michael Düll <mail@akurei.me> PGP-Key: AAAEE882
+# Maintainer: Michael Düll <mail@akurei.me>
pkgname=python2-potr
-pkgver=1.0.0beta6
-pkgrel=3
-pkgdesc="This is a pure Python OTR implementation; it does not bind to libotr."
+pkgver=1.0.0
+pkgrel=4
+pkgdesc="This is a pure Python2 OTR implementation; it does not bind to libotr."
arch=(any)
url="https://github.com/afflux/pure-python-otr"
license=('LGPL')
depends=('python2' 'python2-crypto')
conflicts=('python-potr-git' 'python-potr')
replaces=('python-potr')
-options=(!emptydirs)
-source=("https://github.com/afflux/pure-python-otr/tarball/${pkgver}")
+#options=(!emptydirs)
+source=("https://github.com/python-otr/pure-python-otr/archive/${pkgver}.tar.gz")
+sha512sums=('46b0dab24cab68e695661c5982ba25823e39540ecef7e90693898342f44e52afa549d8708166ebef81474aee3f846d8b76690e3061fa1bc65147e804751f8f48')
PYTHON=`which python2`
-build() {
- cd $srcdir/afflux*
+#build() {
+# cd $srcdir/afflux*
+# set_python2
+# $PYTHON ./setup.py build
+#}
+
+prepare() {
+ cd $srcdir/pure-python-otr-${pkgver}
set_python2
- $PYTHON ./setup.py build
}
package() {
- cd $srcdir/afflux*
+ cd $srcdir/pure-python-otr-${pkgver}
$PYTHON ./setup.py install --root=$pkgdir/
}
@@ -36,4 +42,3 @@ set_python2() {
# vim:set ts=2 sw=2 et:
-sha512sums=('323ad31e782409b7bd93539dfc0088de8b114075b88de81123b732aff609fbb2a2c06221c52266225ce54e20e9856b25759bae84c93244a1258ccba3825c8b1c')