summaryrefslogtreecommitdiff
path: root/pcr/simtrace/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/simtrace/PKGBUILD')
-rw-r--r--pcr/simtrace/PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/pcr/simtrace/PKGBUILD b/pcr/simtrace/PKGBUILD
index d51db16dc..9540f796a 100644
--- a/pcr/simtrace/PKGBUILD
+++ b/pcr/simtrace/PKGBUILD
@@ -1,24 +1,23 @@
# Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-pkgname=simtrace2
-pkgver=0.7.0
-pkgrel=1
-pkgdesc="Traces the communication between phones and SIM cards with second generation simtrace hardware."
+# it under the terms of the CC0 1.0 License.
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+pkgname=simtrace
+pkgver=1.5
+pkgrel=2
+pkgdesc="Traces the communication between phones and SIM cards with first generation simtrace hardware."
arch=('armv7h' 'i686' 'x86_64')
-url="https://osmocom.org/projects/simtrace2"
+url="https://osmocom.org/projects/simtrace/wiki/SIMtrace"
license=('GPL2') # GPLv2-only according to the source files headers
+replaces=('simtrace-git')
depends=('libosmocore' 'libusb' 'lksctp-tools' 'talloc')
-makedepends=('make' 'gcc' 'git' 'pkg-config')
-source=("git://git.osmocom.org/simtrace2#tag=$pkgver")
+makedepends=('git')
+source=("git://git.osmocom.org/simtrace.git#tag=v$pkgver")
sha512sums=('SKIP')
build() {
cd "$srcdir/$pkgname/host"
- autoreconf -fi
- ./configure
make
}