summaryrefslogtreecommitdiff
path: root/pcr/simtrace2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/simtrace2/PKGBUILD')
-rw-r--r--pcr/simtrace2/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/pcr/simtrace2/PKGBUILD b/pcr/simtrace2/PKGBUILD
new file mode 100644
index 000000000..5a24eb1d6
--- /dev/null
+++ b/pcr/simtrace2/PKGBUILD
@@ -0,0 +1,28 @@
+# Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the CC0 1.0 License.
+# Maintainer: Parabola Hackers <dev@lists.parabola.nu>
+
+pkgname=simtrace2
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Traces the communication between phones and SIM cards with second generation simtrace hardware."
+arch=('armv7h' 'i686' 'x86_64')
+url="https://osmocom.org/projects/simtrace2"
+license=('GPL2') # GPLv2-only according to the source files headers
+depends=('libosmocore' 'libusb' 'lksctp-tools' 'talloc')
+makedepends=('git')
+source=("git://git.osmocom.org/simtrace2#tag=$pkgver")
+sha512sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname/host"
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/host"
+ make DESTDIR=$pkgdir install
+}