summaryrefslogtreecommitdiff
path: root/pcr/texlive-localmanager/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/texlive-localmanager/PKGBUILD')
-rw-r--r--pcr/texlive-localmanager/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/pcr/texlive-localmanager/PKGBUILD b/pcr/texlive-localmanager/PKGBUILD
new file mode 100644
index 000000000..508c46453
--- /dev/null
+++ b/pcr/texlive-localmanager/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer (AUR): XZS <d dot f dot fischer at web dot de>
+# Contributor (AUR): Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor (AUR): Rémy Oudompheng <remy@archlinux.org>
+# Contributor (AUR): Firmicus <francois . archlinux . org>
+# Contrbutor: bill-auger <bill-auger@programmer.net>
+
+
+pkgname=texlive-localmanager
+pkgver=0.7
+pkgrel=1
+pkgdesc="A shell and command-line utility to manage TeXLive"
+arch=('any')
+url="http://wiki.archlinux.org/index.php?title=TeXLive#TeXLive_Local_Manager"
+license=('GPL')
+
+depends=('texlive-core>=2011'
+ 'perl-libwww'
+ 'perl-term-shellui'
+ 'perl-term-readline-gnu'
+ 'perl-list-moreutils'
+ 'perl-lwp-protocol-https')
+install='tllocalmgr.install'
+replaces=('texlive-localmanager-git')
+source=(https://git.archlinux.org/users/remy/texlive-localmanager.git/snapshot/texlive-localmanager-${pkgver}.tar.gz)
+
+sha256sums=('55938e60d0a431f9fadc9a9c62e713a70c112ad9a679c7cb21e1bc1459cb8129')
+
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+
+ install -d $pkgdir/usr/{bin,share/texmf/arch/tlpkg/TeXLive}
+ install -m755 tllocalmgr $pkgdir/usr/bin/
+ cd tlpkg/TeXLive
+ for _f in *; do
+ install -m644 $_f $pkgdir/usr/share/texmf/arch/tlpkg/TeXLive/
+ done
+}