summaryrefslogtreecommitdiff
path: root/pcr/thinkfan/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/thinkfan/PKGBUILD')
-rw-r--r--pcr/thinkfan/PKGBUILD43
1 files changed, 28 insertions, 15 deletions
diff --git a/pcr/thinkfan/PKGBUILD b/pcr/thinkfan/PKGBUILD
index 6a9f587e1..ee6346f39 100644
--- a/pcr/thinkfan/PKGBUILD
+++ b/pcr/thinkfan/PKGBUILD
@@ -1,22 +1,33 @@
-# Maintainer (Arch): nblock <nblock [/at\] archlinux DOT us>
-# Contributor (Arch): Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
-# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Maintainer (aur): Barry Smith <brrtsm at gmail.com>
+# Contributor: nblock <nblock [/at\] archlinux DOT us>
+# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
+# Maintainer: Omar Vega Ramos <ovruni.gnu.org.pe>
+# Contributor: Wael Karram <wael@waelk.tech>
+# Contributor: bill-auger <bill-auger@programmer.net>
+
+
+# parabola changes and rationale:
+# - add sodep on 'yaml-cpp'
+
pkgname=thinkfan
-pkgver=0.9.3
-pkgrel=1
+pkgver=1.3.1
+pkgrel=2
pkgdesc="A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi"
-url="http://thinkfan.sourceforge.net/"
+url="https://github.com/vmatare/thinkfan"
arch=('i686' 'x86_64')
+arch+=('armv7h')
makedepends=('cmake')
-depends=('libatasmart')
+depends=('libatasmart' 'yaml-cpp')
+depends+=('libyaml-cpp.so')
optdepends=('lm_sensors: hwmon support')
+backup=('etc/systemd/system/thinkfan.service.d/override.conf')
license=('GPL')
-source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vmatare/$pkgname/archive/$pkgver.tar.gz"
'thinkfan.service'
'thinkpad_acpi.conf')
-sha256sums=('b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b'
- '90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f'
+sha256sums=('9466c8c82b7c4333b280fa66445ab26185ffbb4aada6bcb4a164eed742f8d78c'
+ '625730e33fae251f3a1cc8259b222089fb45ada08e9cf5c816ea1cde6560e989'
'28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f')
install=thinkfan.install
@@ -30,13 +41,15 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -d -m755 "$pkgdir"/usr/{bin,lib/{modprobe.d,systemd/system},share/{doc/"$pkgname"/{,examples},man/man1}}
+ install -d -m755 "$pkgdir"/usr/{bin,lib/{modprobe.d,systemd/system},share/{doc/"$pkgname"/{,examples},man/man{1,5}}}
+ install -d -m755 "$pkgdir"/etc/systemd/system/thinkfan.service.d
install -D -m755 "$pkgname" "$pkgdir"/usr/bin
- install -D -m644 README NEWS "$pkgdir"/usr/share/doc/"$pkgname"
install -D -m644 examples/* "$pkgdir"/usr/share/doc/"$pkgname"/examples
- install -D -m644 src/"$pkgname".1 "$pkgdir"/usr/share/man/man1
- install -D -m644 ../"$pkgname".service "$pkgdir"/usr/lib/systemd/system
- install -D -m644 ../thinkpad_acpi.conf "$pkgdir"/usr/lib/modprobe.d
+ install -D -m644 "$pkgname".1 "$pkgdir"/usr/share/man/man1
+ install -D -m644 "$pkgname".conf.5 "$pkgdir"/usr/share/man/man5
+ install -D -m644 "$srcdir/$pkgname".service rcscripts/systemd/thinkfan-{sleep,wakeup}.service "$pkgdir"/usr/lib/systemd/system
+ install -D -m644 rcscripts/systemd/override.conf "$pkgdir"/etc/systemd/system/thinkfan.service.d
+ install -D -m644 "$srcdir"/thinkpad_acpi.conf "$pkgdir"/usr/lib/modprobe.d
}
# vim:set ts=2 sw=2 noet: