summaryrefslogtreecommitdiff
path: root/pcr/tomb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/tomb/PKGBUILD')
-rw-r--r--pcr/tomb/PKGBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/pcr/tomb/PKGBUILD b/pcr/tomb/PKGBUILD
index 4cdce0481..c85d71135 100644
--- a/pcr/tomb/PKGBUILD
+++ b/pcr/tomb/PKGBUILD
@@ -1,54 +1,56 @@
-# Maintainer (AUR): parazyd <parazyd@dyne.org>
-# Contributor (AUR): nignux <nignux@freaknet.org>
-# Contributor (AUR): fauno <fauno@parabola.nu>
-# Contributor (AUR): BoySka
+# Maintainer (aur): Alexandre Pujol <alexandre@pujol.io>
+# Contributor: parazyd <parazyd@dyne.org>
+# Contributor: nignux <nignux@freaknet.org>
+# Contributor: fauno <fauno@parabola.nu>
+# Contributor: BoySka
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgbase=tomb
pkgname=(tomb tomb-kdf)
-pkgver=2.5
+pkgver=2.9
pkgrel=2
pkgdesc="Crypto Undertaker, a simple tool to manage encrypted storage"
arch=('i686' 'x86_64')
+arch+=('armv7h')
url="https://www.dyne.org/software/tomb/"
license=('GPL3')
install=${pkgname}.install
source=(
- https://files.dyne.org/${pkgname}/Tomb-${pkgver}.tar.gz
- https://files.dyne.org/${pkgname}/Tomb-${pkgver}.tar.gz.sha
- https://files.dyne.org/${pkgname}/Tomb-${pkgver}.tar.gz.asc
+ https://files.dyne.org/tomb/releases/Tomb-${pkgver}.tar.gz
+ https://files.dyne.org/tomb/releases/Tomb-${pkgver}.tar.gz.sha
+ https://files.dyne.org/tomb/releases/Tomb-${pkgver}.tar.gz.asc
)
# The first hash comes from the .sha file
-sha256sums=('8c03693cd4aa1fa7eccbad55dec02474750be7b75180b51f1085ab671bc58689'
- 'f02373771751371b530776c03561ace67cd7c5655499d766282acc5e736173ba'
- 'ca1087639a6eb9acb6bc7a0af4839a998034a4e8df2fbfdd02523f23e0779938')
+sha256sums=('b3a23c6680815f7557a3c4bd73d2b2dbde870a62357fcbf9b33089afae75d68c'
+ '4f57af24b3b39ae1774ac0bca5af5dacf26465bbd55dc954001069fecce5f2a2'
+ 'SKIP')
-# The public key is found at http://jaromil.dyne.org/contact
-# gpg --recv-keys 0x73b35da54acb7d10
+# get from https://jaromil.dyne.org/jaromil.pub
validpgpkeys=('6113D89CA825C5CEDD02C87273B35DA54ACB7D10')
build() {
- cd ${srcdir}/Tomb-${pkgver}/extras/kdf-keys
+ cd "${srcdir}/Tomb-${pkgver}/extras/kdf-keys"
make
}
# The checks require root access
#check() {
-# cd ${srcdir}/${pkgname}-${pkgver}
+# cd "${srcdir}/Tomb-${pkgver}"
# make test
#}
package_tomb() {
- depends=('bc' 'cryptsetup' 'gnupg' 'sudo' 'zsh' 'e2fsprogs')
+ depends=('cryptsetup' 'gnupg' 'sudo' 'zsh' 'e2fsprogs' 'inetutils')
optdepends=(
'steghide: steganography'
'dcfldd: show nice progress during massive I/O'
- 'wipe: secure file deletion'
'qrencode: for paper backups of keys'
'swish-e: file content indexer'
+ 'lsof: allows the operation slam'
)
+ # arch=('any') # librerelease fails to detect sub-packages with conflicting 'arch'
cd "${srcdir}/Tomb-${pkgver}"
make DESTDIR="${pkgdir}" PREFIX=/usr install