summaryrefslogtreecommitdiff
path: root/pcr/uboot-tools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/uboot-tools/PKGBUILD')
-rw-r--r--pcr/uboot-tools/PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/pcr/uboot-tools/PKGBUILD b/pcr/uboot-tools/PKGBUILD
index 65fa2cfc8..d1a084f54 100644
--- a/pcr/uboot-tools/PKGBUILD
+++ b/pcr/uboot-tools/PKGBUILD
@@ -1,26 +1,31 @@
# $Id$
-# Maintainer (Arch): Anatol Pomozov
-# Contributor (Arch): Michael Lass <bevan@bi-co.net>
-# Contributor (Arch): Philipp Schrader <philipp.schrader+arch@gmail.com>
+# Maintainer (arch): Anatol Pomozov
+# Contributor: Michael Lass <bevan@bi-co.net>
+# Contributor: Philipp Schrader <philipp.schrader+arch@gmail.com>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Parabola changes and rationale:
+# - Change architecture to armv7h: uboot-tools is already available in
+# Parabola i686 and x86_64 through Arch Linux and Arch Linux 32's
+# community repositories
+
pkgname=uboot-tools
-pkgver=2017.07
+pkgver=2021.04
pkgrel=1
pkgdesc='U-Boot bootloader utility tools'
arch=(armv7h)
-url='http://www.denx.de/wiki/U-Boot/WebHome'
+url='https://www.denx.de/wiki/U-Boot/WebHome'
license=(GPL)
depends=(openssl)
source=(ftp://ftp.denx.de/pub/u-boot/u-boot-$pkgver.tar.bz2{,.sig})
-validpgpkeys=('E872DB409C1A687EFBE8633687F9F635D31D7652')
-sha256sums=('5374bfdc8acb9a38c025371b1ff20f45e7533668e84e685d0df5d9e7c0e4feff'
- 'SKIP')
+validpgpkeys=('1A3C7F70E08FAB1707809BBF147C39FF9634B72C')
+sha1sums=('a69cf9cf8ddda0935b0bfed86e90fde1124f133d'
+ 'SKIP')
build() {
cd u-boot-$pkgver
make defconfig
- make tools-all
+ make tools-all KBUILD_HOSTLDFLAGS=${LDFLAGS}
}
package() {