summaryrefslogtreecommitdiff
path: root/pcr/vim-autotag/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/vim-autotag/PKGBUILD')
-rw-r--r--pcr/vim-autotag/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/pcr/vim-autotag/PKGBUILD b/pcr/vim-autotag/PKGBUILD
new file mode 100644
index 000000000..44ff0c603
--- /dev/null
+++ b/pcr/vim-autotag/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Daniel Milewski <niitotantei@riseup.net>
+
+pkgname=vim-autotag
+pkgver=r5.433b6b5
+_gitcommit=433b6b5be330615c4cb97ec748a773115dcced60
+pkgrel=1
+pkgdesc='Automatically discover and "properly" update ctags files on save'
+arch=(any)
+url=https://github.com/craigemery/vim-autotag
+license=(custom:vim)
+groups=(vim-plugins)
+mkdepends=(git)
+depends=(ctags vim)
+mksource=($pkgname-$pkgver::git+https://github.com/craigemery/$pkgname.git#commit=$_gitcommit)
+source=(https://repo.parabola.nu/other/$pkgname/$pkgname-$pkgver.tar.gz LICENSE)
+mksha256sums=(SKIP)
+sha256sums=(3fe4270ec84a4299866c6c205a9869055a72194c6482fed7a7c4bb99acc5b5b0
+ 62743e7d4354d94ef0957dd8aa43983b9244eb3cd820075b18f10b9d37d31c2d)
+
+mksource()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+
+ rm .gitignore
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm 644 plugin/autotag.py "$pkgdir/usr/share/vim/vimfiles/plugin/autotag.py"
+ install -Dm 644 plugin/autotag.vim "$pkgdir/usr/share/vim/vimfiles/plugin/autotag.vim"
+
+ install -Dm 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}