summaryrefslogtreecommitdiff
path: root/pcr/xtables-addons/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/xtables-addons/PKGBUILD')
-rw-r--r--pcr/xtables-addons/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/pcr/xtables-addons/PKGBUILD b/pcr/xtables-addons/PKGBUILD
index 2a26481ba..1db9c2566 100644
--- a/pcr/xtables-addons/PKGBUILD
+++ b/pcr/xtables-addons/PKGBUILD
@@ -1,9 +1,9 @@
+# Contributor (Arch): Thiago Coutinho <root at thiagoc . net>
# Maintainer : Aurélien DESBRIÈRES <aurelien@hackers.camp>
-# Contributor: Vladimir Kutyavin <vlkut@bk.ru>
pkgname=xtables-addons
-pkgver=2.5
-pkgrel=1
-pkgdesc="Successor to patch-o-matic(-ng). Additional extensions for iptables, ip6tables, etc. CHAOS, TARPIT, TEE, DELUDE and other targets; condition, geoip, ipp2p and other matches. Includes ipset package."
+pkgver=2.6
+pkgrel=3
+pkgdesc="Successor to patch-o-matic(-ng). Additional extensions for iptables, ip6tables, etc. CHAOS, TARPIT, TEE, DELUDE and other targets; condition, geoip, ipp2p and other matches. Includes ipset package."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://xtables-addons.sourceforge.net/"
@@ -12,7 +12,9 @@ makedepends=('linux-api-headers' 'linux-headers')
conflicts=(ipset)
replaces=(ipset)
provides=(ipset)
+install='xtables-addons.install'
source=(http://download.sourceforge.net/project/xtables-addons/Xtables-addons/$pkgver/$pkgname-$pkgver.tar.xz)
+md5sums=('087835ba7e564481b6fd398692268340')
build() {
cd $srcdir/$pkgname-$pkgver
@@ -28,5 +30,9 @@ build() {
package () {
cd $srcdir/$pkgname-$pkgver
make DESTDIR=$pkgdir install || return 1
+ mv $pkgdir/lib/* $pkgdir/usr/lib/
+ mv $pkgdir/usr/lib/modules/$(uname -r)/extra $pkgdir/usr/lib/modules/$(uname -r)/$(readlink /usr/lib/modules/$(uname -r)/extramodules)
+ rmdir $pkgdir/lib
+ mv $pkgdir/usr/sbin $pkgdir/usr/bin
chmod a-x $pkgdir/usr/lib/iptables/*.so
}