summaryrefslogtreecommitdiff
path: root/pcr/zimlib/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/zimlib/PKGBUILD')
-rw-r--r--pcr/zimlib/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/pcr/zimlib/PKGBUILD b/pcr/zimlib/PKGBUILD
new file mode 100644
index 000000000..2bf35f3e0
--- /dev/null
+++ b/pcr/zimlib/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor (Arch): Yaron de Leeuw < me@jarondl.net >
+
+pkgname=zimlib
+pkgver=1.2
+pkgrel=1
+pkgdesc="The standard implementation of the ZIM specification - openzim"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://openzim.org/wiki/Zimlib"
+license=('GPL2')
+depends=('xz' 'gcc-libs')
+conflicts=('zimlib-git')
+source=("http://www.openzim.org/download/zimlib-$pkgver.tar.gz")
+sha256sums=('ce119c2c5aa4cce24aed387da8072c0b0a39f9d93c832a28908d0b76d85afd43')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}