summaryrefslogtreecommitdiff
path: root/pcr/zulucrypt/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/zulucrypt/PKGBUILD')
-rw-r--r--pcr/zulucrypt/PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/pcr/zulucrypt/PKGBUILD b/pcr/zulucrypt/PKGBUILD
index 965736fa7..972978b7d 100644
--- a/pcr/zulucrypt/PKGBUILD
+++ b/pcr/zulucrypt/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer (AUR): Salan54 <salan at fremenil dot com>
+# Maintainer (aur): Salan54 <salan at fremenil dot com>
# Created: 2013-03-17
-# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+# Maintainer: Aurélien Desbrières <aurelien@hackers.camp>
+
# parabola changes and rationale:
-# - added .install file to update desktop database
+# - added support for armv7h
+
pkgname=zulucrypt
-pkgver=5.4.0
+pkgver=6.2.0
pkgrel=1
_altpkgname=zuluCrypt
pkgdesc="A cli and gui frontend to cryptsetup"
-url="http://mhogomchungu.github.io/${_altpkgname}"
-arch=('x86_64' 'i686' 'armv7h')
+url="https://mhogomchungu.github.io/${_altpkgname}"
+arch=('x86_64' 'i686')
+arch+=('armv7h')
license=('GPL')
depends=('cryptsetup' 'qt5-base' 'libpwquality' 'libsecret' 'libxkbcommon-x11' )
optdepends=('kwalletmanager: retrieve volume keys from kde kwallet')
-conflicts=('zulucrypt-git')
makedepends=('cmake')
-source=("https://github.com/mhogomchungu/zuluCrypt/releases/download/${pkgver}/${_altpkgname}-${pkgver}.tar.bz2")
-md5sums=('420a7375229e52a2b8458ceb63ff9ee5')
-sha256sums=('6cb499a1e9ec0f23f9411b192df5260eda601ac33c836e17370de2a33876b3e8')
-install=${pkgname}.install
+source=("https://github.com/mhogomchungu/zuluCrypt/releases/download/${pkgver}/${_altpkgname}-${pkgver}.tar.xz")
+md5sums=('ca53ef782f84ac62d0e95ec0fc03ad1c')
+sha256sums=('090f3d561add1c5a5fc5158bf346155d43e2b42e7c47939a403ae2f8dcf8eaa3')
build() {
cd "${srcdir}/${_altpkgname}-${pkgver}"