summaryrefslogtreecommitdiff
path: root/unmaintained/uboot-cubox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/uboot-cubox/PKGBUILD')
-rw-r--r--unmaintained/uboot-cubox/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/unmaintained/uboot-cubox/PKGBUILD b/unmaintained/uboot-cubox/PKGBUILD
new file mode 100644
index 000000000..a27e33472
--- /dev/null
+++ b/unmaintained/uboot-cubox/PKGBUILD
@@ -0,0 +1,26 @@
+# U-Boot: CuBox (Dove)
+# Maintainer: André Silva <emulatorman@hyperbola.info>
+
+buildarch=4
+
+pkgname=uboot-cubox
+pkgver=2009.08
+pkgrel=1.parabola1
+pkgdesc="U-Boot for CuBox (Dove)"
+arch=('armv7h')
+url="https://projects.parabola.nu/abslibre.git/"
+license=('GPL')
+makedepends=('uboot-tools')
+depends=('linux-libre')
+replaces=('uboot-cubox-linux-libre')
+conflicts=('uboot4extlinux-cubox' 'uboot4grub-cubox')
+backup=('boot/boot.scr')
+_commit=814386d3e43b8ab8d81f04aa7fe402952503d8fe
+source=('boot.txt')
+md5sums=('02356c39d1e254e3f64c016be3895191')
+
+package() {
+ mkimage -A arm -O linux -T script -C none -n "Boot script" -d boot.txt boot.scr
+ mkdir -p "${pkgdir}"/boot
+ cp boot.scr "${pkgdir}"/boot
+}