summaryrefslogtreecommitdiff
path: root/~emulatorman/icedove-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~emulatorman/icedove-libre/PKGBUILD')
-rw-r--r--~emulatorman/icedove-libre/PKGBUILD101
1 files changed, 101 insertions, 0 deletions
diff --git a/~emulatorman/icedove-libre/PKGBUILD b/~emulatorman/icedove-libre/PKGBUILD
new file mode 100644
index 000000000..5ea3ff98f
--- /dev/null
+++ b/~emulatorman/icedove-libre/PKGBUILD
@@ -0,0 +1,101 @@
+# Maintainer : Márcio Silva <coadde@lavabit.com>
+# Maintainer : André Silva <emulatorman@lavabit.com>
+
+# We're getting this from Debian Experimental
+_debname=icedove
+_debver=17.0.2
+_debrel=1
+_debrepo=http://ftp.debian.org/debian/pool/main/
+debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
+
+_pkgname=${_debname}
+pkgname=${_debname}-libre
+pkgver=${_debver}.${_debrel}
+pkgrel=1
+pkgdesc="A libre version of Debian Icedove, the Standalone Mail/News reader based on Mozilla Thunderbird."
+arch=('i586' 'i686' 'x86_64' 'mips64el')
+license=('GPL2' 'MPL' 'LGPL')
+url="http://packages.debian.org/source/experimental/${_pkgname}"
+depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hicolor-icon-theme' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'mozilla-searchplugins' 'nss' 'sqlite' 'startup-notification')
+makedepends=('unzip-libre' 'zip' 'pkg-config' 'python2' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13' 'quilt')
+optdepends=('libcanberra: for sound support')
+replaces=('thunderbird')
+conflicts=('thunderbird')
+provides=('thunderbird')
+install=${_pkgname}.install
+source=("${_debrepo}/`debfile ${_debname}`_${_debver}.orig.tar.bz2"
+ "${_debrepo}/`debfile ${_debname}`_${_debver}-${_debrel}.debian.tar.gz"
+ mozconfig
+ channel-prefs.js
+ vendor.js
+ makefile.patch
+ branding.patch
+ ${_pkgname}.desktop
+ Icedove-branding.patch)
+options=(!emptydirs)
+md5sums=('3f7679bb98ae99be5adf73fd0025b00e'
+ '7440def324766bcc61b91185226f8824'
+ 'd6d58d3104a44624e0a3d227cdf1c211'
+ '476ec205162340fb0679f522c9d31c3b'
+ '4eecc4fc5aafaf0da651a09eadc90bee'
+ 'c4ed43e85945e180a89cce03e45ec62c'
+ '126b1446212396c33220936c01d9592d'
+ 'e785e0c267f4435ae1a9aa0b03bcacfb'
+ 'ea5f7a06967f561d47d7e5c35b23de6f')
+
+build() {
+ export QUILT_PATCHES=debian/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
+ export LDFLAGS="${LDFLAGS} -Wl,--as-needed,-rpath,/usr/lib/${_pkgname}"
+ export PYTHON="/usr/bin/python2"
+ export DEBIAN_BUILD="comm-release"
+ mv debian "${srcdir}/${DEBIAN_BUILD}"
+ cd "${srcdir}/${DEBIAN_BUILD}"
+ mv debian/${_pkgname}-branding "${srcdir}/${DEBIAN_BUILD}/mail/branding/${_pkgname}"
+ cp -a debian/app-icons/${_pkgname}big.svg debian/app-icons/${_pkgname}_icon.svg
+ for i in 16x16 22x22 24x24 32x32 48x48 256x256; do
+ install -Dm644 "debian/app-icons/${_pkgname}${i/x*/}.png" "${srcdir}/${DEBIAN_BUILD}/mail/branding/${_pkgname}/mailicon${i/x*/}.png"
+ done
+ for i in 48x48 64x64; do
+ install -Dm644 "debian/app-icons/${_pkgname}${i/x*/}.png" "${srcdir}/${DEBIAN_BUILD}/mail/branding/${_pkgname}/content/icon${i/x*/}.png"
+ done
+
+ # This patch has a orthographic issue ("Icdove" instead of "Icedove") in MOZ_APP_BASENAME line for confvars.sh
+ rm -v debian/patches/debian-hacks/Icedove-branding.patch || true
+
+ quilt push -av
+
+ patch -Np1 -i "${srcdir}/makefile.patch" # small fix
+ patch -Np1 -i "${srcdir}/branding.patch" # fixing branding
+ patch -Np1 -i "${srcdir}/Icedove-branding.patch" # debian patch fixed version
+
+ cp "${srcdir}/mozconfig" .mozconfig
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}"
+}
+
+package() {
+ cd "${srcdir}/${DEBIAN_BUILD}"
+
+ make -j1 -f client.mk DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${srcdir}/vendor.js" "${pkgdir}/usr/lib/${_pkgname}/defaults/preferences/vendor.js"
+
+ # Recommend free addons
+ install -m644 "${srcdir}/channel-prefs.js" "${pkgdir}/usr/lib/${_pkgname}/defaults/pref/channel-prefs.js"
+
+ for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
+ install -Dm644 "debian/app-icons/${_pkgname}${i/x*/}.png" "${pkgdir}/usr/share/icons/hicolor/$i/apps/${_pkgname}.png"
+ done
+ install -Dm644 "debian/app-icons/${_pkgname}_icon.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.svg"
+
+ install -Dm644 "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ rm -rf "${pkgdir}"/usr/lib/${_pkgname}/{dictionaries,hyphenation,searchplugins}
+ ln -sf /usr/share/hunspell "${pkgdir}/usr/lib/${_pkgname}/dictionaries"
+ ln -sf /usr/share/hyphen "${pkgdir}/usr/lib/${_pkgname}/hyphenation"
+ ln -sf /usr/lib/mozilla/searchplugins "${pkgdir}/usr/lib/${_pkgname}/searchplugins"
+ # We don't want the development stuff
+ rm -r "${pkgdir}"/usr/{include,lib/$_pkgname-devel,share/idl}
+}