summaryrefslogtreecommitdiff
path: root/~emulatorman/iceweasel-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~emulatorman/iceweasel-libre/PKGBUILD')
-rw-r--r--~emulatorman/iceweasel-libre/PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/~emulatorman/iceweasel-libre/PKGBUILD b/~emulatorman/iceweasel-libre/PKGBUILD
index fca35cc42..4f7d77337 100644
--- a/~emulatorman/iceweasel-libre/PKGBUILD
+++ b/~emulatorman/iceweasel-libre/PKGBUILD
@@ -14,7 +14,7 @@ _pgo=false
# We're getting this from Debian Experimental
_debname=iceweasel
-_debver=18.0
+_debver=18.0.1
_debrel=1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -22,7 +22,7 @@ debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
_pkgname=iceweasel
pkgname=iceweasel-libre
pkgver=$_debver.$_debrel
-pkgrel=5
+pkgrel=1
if [ -z "$pkgname" ]; then pkgname=$_pkgname; fi
if $_pgo; then
@@ -52,21 +52,19 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.bz2"
iceweasel-install-dir.patch
vendor.js
shared-libs.patch
- bug677092.patch
replace-urls.txt
Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch)
-md5sums=('366e1e4847d7e00eba77ee5a4be0d3db'
- '6a571d3a3b355c331f67d57702f4fccf'
+md5sums=('5d481dd35a304702d1f311eeb3f1149f'
+ '6a4781e8ddc1b166f36930c4864e095f'
'619e8f7c8596838a7daf2b7ce2e54cd3'
'ac29b01c189f20abae2f3eef1618ffc0'
'1ee2d4bcacee73d671b9ffa17a02abaa'
- '2823e0ecdefc16b590a9997f9228924a'
+ '7b9e5996dd9fe0b186a43a297db1c6b5'
'abf5ecb74caa857abb42bcfbb3442d9c'
'6dd547c72bb875a3101135a1c32d4783'
'52e52f840a49eb1d14be1c0065b03a93'
- '23520aca140fb0dd3e1b6f21b21f591f'
'a8fc4658d45b6bf9350023e5c3f34e56'
- '65f68090d2a69b467bd2707d0c4ea3bd')
+ '46a4b19b414065b99b870ea79b454f6e')
if [ "$_pkgname" != "$pkgname" ]; then
provides+=("$_pkgname=$pkgver")
@@ -100,11 +98,7 @@ build() {
patch -Np1 -i "$srcdir/Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch" # Adding fixed Bug-756390-Make-the-Reset-Firefox-feature-more-gener.patch
patch -Np1 -i "$srcdir/iceweasel-install-dir.patch" # install to /usr/lib/$_pkgname
patch -Np1 -i "$srcdir/shared-libs.patch"
-
- # Back out https://bugzilla.mozilla.org/show_bug.cgi?id=677092
- # in order to fix https://bugzilla.mozilla.org/show_bug.cgi?id=818468
- patch -Rp1 -i ../bug677092.patch
-
+
# Replace common URLs
sed '/^#/d' ../replace-urls.txt | while read -r moz_url gnu_url; do
if [[ -n $moz_url ]]; then
@@ -115,12 +109,12 @@ build() {
| xargs -d '\n' --no-run-if-empty sed -ri "s<${moz_url}<${gnu_url}<g"
fi
done
-
+
# Patch anything that's left
patch -Np1 -i "$srcdir/libre.patch"
cp "$srcdir/mozconfig" .mozconfig # Load our build config, disable SafeSearch
-
+
if $_pgo; then
cat "$srcdir/mozconfig.pgo" >> .mozconfig
fi