summaryrefslogtreecommitdiff
path: root/~fauno/notmuch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~fauno/notmuch/PKGBUILD')
-rw-r--r--~fauno/notmuch/PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/~fauno/notmuch/PKGBUILD b/~fauno/notmuch/PKGBUILD
index 6e9c92ea4..95270b3d4 100644
--- a/~fauno/notmuch/PKGBUILD
+++ b/~fauno/notmuch/PKGBUILD
@@ -3,25 +3,26 @@
# Maintainer: Richard Murri <admin@richardmurri.com>
pkgname=notmuch
-pkgver=0.11.1
+pkgver=0.12
pkgrel=1
pkgdesc="Notmuch is not much of an email program"
arch=(i686 x86_64 mips64el)
url="http://notmuchmail.org/"
license=('GPL3')
depends=('xapian-core' 'gmime' 'talloc')
-makedepends=('python2' 'emacs-nox' 'gnupg' 'ruby' 'pkgconfig')
+makedepends=('python2' 'emacs' 'gnupg' 'ruby' 'pkgconfig')
optdepends=('emacs: for using the emacs interface'
'vim: for using the vim interface'
'python2: for using the python bindings'
'ruby: for using the ruby bindings'
'gnupg: for email encryption')
-source=("https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-${pkgrel}-any.src.tar.xz"
- # "http://notmuchmail.org/releases/${pkgname}-${pkgver}.tar.gz"
- )
+options=(!distcc !makeflags)
+
+source=("http://notmuchmail.org/releases/${pkgname}-${pkgver}.tar.gz")
+md5sums=('466974db1d8a215c6a2d7cca7c969b4f')
build() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}-"*
./configure --prefix=/usr --sysconfdir=/etc
make
@@ -32,12 +33,12 @@ build() {
}
check() {
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}-"*
make test
}
package(){
- cd "$srcdir/${pkgname}-${pkgver}"
+ cd "$srcdir/${pkgname}-"*
make DESTDIR="$pkgdir/" LIBDIR_IN_LDCONFIG=0 install
install -D notmuch $pkgdir/usr/sbin/notmuch
@@ -62,7 +63,3 @@ package(){
sed -i -e 's,/site_ruby,,g' Makefile
make prefix=${pkgdir}/usr install
}
-md5sums=('764abeb6e277c4c03bd64914c72d89a8'
- '886b9fed1326c82aa223b0cfaf717522'
- 'e36987a69d0c1e57570f5a854054a729')
-md5sums=('764abeb6e277c4c03bd64914c72d89a8')