summaryrefslogtreecommitdiff
path: root/~gnutoo/public-archive/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~gnutoo/public-archive/PKGBUILD')
-rw-r--r--~gnutoo/public-archive/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/~gnutoo/public-archive/PKGBUILD b/~gnutoo/public-archive/PKGBUILD
new file mode 100644
index 000000000..cbe841b49
--- /dev/null
+++ b/~gnutoo/public-archive/PKGBUILD
@@ -0,0 +1,33 @@
+# Copyright (C) 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the CC0 1.0 License.
+# Maintainer: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+
+# Note that this software works but it's not completely ready for
+# public usage yet.
+
+pkgname=public-archive
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Various scripts that don't fit elsewhere"
+arch=('any')
+url='https://git.sr.ht/~gnutoo/public-archive'
+license=('GPL3')
+makedepends=('autoconf'
+ 'automake'
+ 'git'
+ 'gcc-go')
+source=("git+https://git.sr.ht/~gnutoo/public-archive/#commit=v${pkgver}")
+sha512sums=('SKIP')
+
+build(){
+ cd ${pkgname}
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package(){
+ cd ${pkgname}
+ make install DESTDIR="${pkgdir}"
+}