summaryrefslogtreecommitdiff
path: root/~lukeshu/collectd-systemd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~lukeshu/collectd-systemd/PKGBUILD')
-rw-r--r--~lukeshu/collectd-systemd/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/~lukeshu/collectd-systemd/PKGBUILD b/~lukeshu/collectd-systemd/PKGBUILD
new file mode 100644
index 000000000..1b1125d8c
--- /dev/null
+++ b/~lukeshu/collectd-systemd/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luke Shumaker <lukeshu@sbcglobal.net>
+
+pkgname=collectd-systemd
+pkgver=20170820
+pkgdesc="A collectd plugin to read systemd unit and job counts"
+url="https://git.lukeshu.com/$pkgname.git"
+license=('Apache')
+
+pkgrel=1
+arch=('any')
+depends=('collectd' 'systemd' 'python2-dbus')
+source=("https://repo.parabola.nu/other/~lukeshu/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('9a5bf4e8f6f775ae98182a0577c91371')
+
+_config=(
+ prefix=/usr
+)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make "${_config[@]}"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make "${_config[@]}" install DESTDIR="$pkgdir"
+}