summaryrefslogtreecommitdiff
path: root/~mtjm/zbar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~mtjm/zbar/PKGBUILD')
-rw-r--r--~mtjm/zbar/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/~mtjm/zbar/PKGBUILD b/~mtjm/zbar/PKGBUILD
new file mode 100644
index 000000000..64b47b5dc
--- /dev/null
+++ b/~mtjm/zbar/PKGBUILD
@@ -0,0 +1,28 @@
+# Parabola maintainer: Michał Masłowski <mtjm@mtjm.eu>
+# Based on https://aur.archlinux.org/packages.php?ID=33527
+# Contributor: Radu Andries <admiral0@tuxfamily.org>
+pkgname=zbar
+pkgver=0.10
+pkgrel=1
+pkgdesc="A library for reading bar codes from various sources"
+arch=('i686' 'x86_64')
+url="http://zbar.sourceforge.net/"
+license=('LGPL')
+depends=('glibc')
+provides=()
+source=("http://downloads.sourceforge.net/project/zbar/zbar/$pkgver/zbar-$pkgver.tar.bz2")
+options=(!libtool !emptydirs)
+
+# Disabled nearly everything since I don't need it and some of it needs fixes.
+
+build() {
+ cd "$srcdir/zbar-$pkgver"
+
+ ./configure --prefix=/usr --without-qt --disable-video --without-python \
+ --without-imagemagick --without-gtk --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('0fd61eb590ac1bab62a77913c8b086a5')