summaryrefslogtreecommitdiff
path: root/libre/linux-libre-firmware/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2018-04-09 14:49:41 -0300
committerDavid P <megver83@parabola.nu>2018-04-09 14:49:41 -0300
commitaeedbfeaf11bc1a78b873da53ffb5a9aed93a3dd (patch)
tree8c6934ed0a1feec74ce41d7a6cc86dc76d340751 /libre/linux-libre-firmware/PKGBUILD
parent5f9e7fba0c879546703ef4f3580b0a148a7c84f7 (diff)
libre/linux-libre-firmware: update prepare() and build()
Diffstat (limited to 'libre/linux-libre-firmware/PKGBUILD')
-rw-r--r--libre/linux-libre-firmware/PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/libre/linux-libre-firmware/PKGBUILD b/libre/linux-libre-firmware/PKGBUILD
index a2d78c816..298491a62 100644
--- a/libre/linux-libre-firmware/PKGBUILD
+++ b/libre/linux-libre-firmware/PKGBUILD
@@ -47,7 +47,7 @@ prepare() {
# Some firmwares download toolchains with wget. We don't want that
patch -p1 -i ../remove-wget.patch
- # Although we still don't use carl9170fw yet, this is a step forward
+ # CARL9170 configuration
cp -Tf ../config src/carl9170fw/.config
sed -e '13s|config/conf|config/conf --config|' \
-i src/carl9170fw/autogen.sh
@@ -55,13 +55,12 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-${pkgver}/src"
- make ath9k_htc
# NOTE: usbdux will only build in 32-bits systems/chroots (i686 and armv7h for instance),
# however compiling it manually (without makepkg) on a 64-bits machine works.
# Building with makepkg in a 64-bits system or chroot ends into a segmentation fault.
# Source: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=887320
-# make cis isci keyspan_pda openfwwf av7110 dsp56k usbdux carl9170fw # ath9k_htc
+ make cis isci keyspan_pda openfwwf av7110 dsp56k usbdux carl9170fw # ath9k_htc
}
package() {