summaryrefslogtreecommitdiff
path: root/libre/nextcloud-client/PKGBUILD
diff options
context:
space:
mode:
authorDavid P. <megver83@parabola.nu>2023-10-25 23:09:40 -0300
committerDavid P. <megver83@parabola.nu>2023-10-25 23:09:40 -0300
commit1081d590690e6b00aaae370ef6207a5ff99c69fe (patch)
tree0d247ea5d1dbb7fa8a61be9f69078af7e41cee6f /libre/nextcloud-client/PKGBUILD
parent1e9b8ae605217ca25153cada01785d53bd6a6ebf (diff)
updpkg: libre/nextcloud-client 2:3.10.0-2.parabola1
Signed-off-by: David P. <megver83@parabola.nu>
Diffstat (limited to 'libre/nextcloud-client/PKGBUILD')
-rw-r--r--libre/nextcloud-client/PKGBUILD94
1 files changed, 57 insertions, 37 deletions
diff --git a/libre/nextcloud-client/PKGBUILD b/libre/nextcloud-client/PKGBUILD
index cec867b4b..5d57543e3 100644
--- a/libre/nextcloud-client/PKGBUILD
+++ b/libre/nextcloud-client/PKGBUILD
@@ -1,16 +1,14 @@
-# Maintainer (arch): Caleb Maclennan <caleb@alerque.com>
-# Maintainer (arch): Chih-Hsuan Yen <yan12125@archlinux.org>
-# Contributor: Tyler Dence <tyzoid@archlinux32.org>
-# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+# Maintainer (Arch): Caleb Maclennan <caleb@alerque.com>
+# Maintainer (Arch): Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor (Arch): Tyler Dence <tyzoid@archlinux32.org>
+# Contributor (Arch): Konstantin Shalygin <k0ste@k0ste.ru>
# Maintainer: David P. <megver83@parabola.nu>
# Contributor: bill-auger <bill-auger@programmer.net>
-
# parabola changes and rationale:
# - build without qt5-webengine
# - disable tests which require networking
-
pkgbase=nextcloud-client
# Put config files for libcloudproviders integration in a separate package as
# there is no simple way yet to disable it.
@@ -19,36 +17,53 @@ pkgname=(nextcloud-client nextcloud-client-cloudproviders)
epoch=2
# Upstream does not provide signed tarballs (yet)
# https://github.com/nextcloud/desktop/issues/1510
-pkgver=3.7.4
-# _pkgver() { curl https://api.github.com/repos/nextcloud/desktop/git/ref/tags/v$pkgver | jq -r .object.sha ; }
-_tag=7edba953d76a836fb61e9d0e5672bf2f004cc105
-pkgrel=1
+pkgver=3.10.0
+_tag=19a02ad0b0146167949a9a06d4cb4a1137df8153
+pkgrel=2
pkgrel+=.parabola1
arch=(x86_64)
arch+=(i686 armv7h)
url='https://nextcloud.com/'
+_url=https://github.com/nextcloud/desktop
license=(GPL)
-makedepends=(libcloudproviders cmocka doxygen extra-cmake-modules git inkscape kio openssl python-sphinx
- qt5-quickcontrols2 qt5-svg qt5-tools qt5-websockets qt5-webengine qtkeychain-qt5 sqlite)
-source=("$pkgbase::git+https://github.com/nextcloud/desktop.git?signed#tag=$_tag")
+makedepends=(cmocka
+ doxygen
+ extra-cmake-modules
+ git
+ inkscape
+ kio5
+ libcloudproviders
+ openssl
+ python-sphinx
+ qt5-quickcontrols2
+ qt5-svg
+ qt5-tools
+ qt5-websockets
+ qtkeychain-qt5
+ sqlite)
+source=("$pkgbase::git+$_url.git?signed#tag=$_tag")
source+=(no-webengine.patch)
-makedepends=( ${makedepends[*]/qt5-webengine/} )
validpgpkeys=(
- A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # one of keys controlled by github.com/camilasan
- 42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # controlled by github.com/misch7
- 17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
- 0739B11EDA696A3616666F6AE04221E85C5BB816 # https://github.com/allexzander
- 267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
- 3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
+ A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # https://github.com/camilasan
+ 42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # https://github.com/misch7
+ 17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
+ 0739B11EDA696A3616666F6AE04221E85C5BB816 # https://github.com/allexzander
+ 267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
+ 3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
)
-sha256sums=('SKIP')
-sha256sums+=('1e6d35210a15b8dfa94582d7db875e6ede2cd6b4e70f12cda02ff0be5a6badfb')
+sha256sums=('SKIP'
+ '1e6d35210a15b8dfa94582d7db875e6ede2cd6b4e70f12cda02ff0be5a6badfb')
pkgver() {
cd $pkgbase
git describe --tags | sed 's/^v//;s/-/+/g'
}
+_pkgver() {
+ curl -fs https://api.github.com/repos/nextcloud/desktop/git/ref/tags/v$pkgver |
+ jq -r .object.sha
+}
+
prepare() {
# tmpdir for check()
mkdir -p tmpdir
@@ -57,10 +72,10 @@ prepare() {
# loops for many server/client combos. Feature is also disabled by default on
# server end in v23.0.3 because it was so problematic. This can abe re-enabled
# when underlying bug squashed:
- # https://github.com/nextcloud/desktop/issues/4241
+ # https://github.com/nextcloud/desktop/issues/5726
sed -i -e '/bulkupload/s/return _.*;$/return false;/' src/libsync/capabilities.cpp
# Disable tests that touch on disabled feature
- sed -i -e '/SyncEngine/s/^/#/' -e '/Capabilities/s/^/#/' test/CMakeLists.txt
+ sed -i -e '/SyncEngine/s/^/#/' -e '/Capabilities/s/^/#/' -e '/SecureFileDrop/s/^/#/' test/CMakeLists.txt
# disable tests which require networking
sed -i -e '/OAuth/s/^/#/' test/CMakeLists.txt
@@ -73,15 +88,13 @@ prepare() {
build() {
cd $pkgbase
- export CFLAGS="${CFLAGS/-fvar-tracking-assignments/}" # error: unknown argument: '-fvar-tracking-assignments' [clang-diagnostic-error]
- export CXXFLAGS="${CXXFLAGS/-fvar-tracking-assignments/}" # error: unknown argument: '-fvar-tracking-assignments' [clang-diagnostic-error]
-
# bundled breakpad in libcrashreporter-qt submodule is too old and does not build with glibc >= 2.26
# Upstream fix: https://github.com/google/breakpad/commit/bddcc58860f522a0d4cbaa7e9d04058caee0db9d
cmake -B build -S . \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_CRASHREPORTER=OFF \
+ -DBUILD_UPDATER=OFF \
-DUNIT_TESTING=ON \
-DPLUGINDIR=lib/qt/plugins # Fix vfs plugin install dir https://github.com/nextcloud/desktop/issues/3781#issuecomment-918918320
@@ -102,16 +115,23 @@ check() {
package_nextcloud-client() {
pkgdesc='Nextcloud desktop client'
- depends=(hicolor-icon-theme libcloudproviders openssl qt5-graphicaleffects qt5-quickcontrols
- qt5-quickcontrols2 qt5-svg qt5-webengine qt5-websockets qtkeychain-qt5 sqlite xdg-utils karchive)
- depends=( ${depends[*]/qt5-webengine/} )
- optdepends=(
- 'kio: integration with Dolphin'
- 'nemo-python: integration with Nemo'
- 'python-nautilus: integration with Nautilus'
- 'python-caja: integration with Caja'
- 'nextcloud-client-cloudproviders: cloudproviders support'
- )
+ depends=(hicolor-icon-theme
+ karchive5
+ libcloudproviders
+ openssl
+ qt5-graphicaleffects
+ qt5-quickcontrols
+ qt5-quickcontrols2
+ qt5-svg
+ qt5-websockets
+ qtkeychain-qt5
+ sqlite
+ xdg-utils)
+ optdepends=('kio5: integration with Dolphin'
+ 'nemo-python: integration with Nemo'
+ 'python-nautilus: integration with Nautilus'
+ 'python-caja: integration with Caja'
+ 'nextcloud-client-cloudproviders: cloudproviders support')
backup=('etc/Nextcloud/sync-exclude.lst')
cd $pkgbase/build