summaryrefslogtreecommitdiff
path: root/libre/nextcloud-client/PKGBUILD
diff options
context:
space:
mode:
authorDavid P <megver83@parabola.nu>2022-01-05 15:12:18 -0500
committerDavid P <megver83@parabola.nu>2022-01-05 15:12:18 -0500
commit13571a574374ecdc1e0aa9c5f19e1a36f6ef02d1 (patch)
treede9e8109e6a6c787aba5c9c140ad2693e5e4ff90 /libre/nextcloud-client/PKGBUILD
parent5a46532946760ffb7b836da1f4b5e32421b77e0e (diff)
updpkg: libre/nextcloud-client 2:3.4.1-1.parabola1
Signed-off-by: David P <megver83@parabola.nu>
Diffstat (limited to 'libre/nextcloud-client/PKGBUILD')
-rw-r--r--libre/nextcloud-client/PKGBUILD125
1 files changed, 68 insertions, 57 deletions
diff --git a/libre/nextcloud-client/PKGBUILD b/libre/nextcloud-client/PKGBUILD
index 9afa9b0fb..36df69a52 100644
--- a/libre/nextcloud-client/PKGBUILD
+++ b/libre/nextcloud-client/PKGBUILD
@@ -1,101 +1,112 @@
# Maintainer (Arch): Chih-Hsuan Yen <yan12125@archlinux.org>
# Contributor (Arch): Tyler Dence <tyzoid@archlinux32.org>
# Contributor (Arch): Konstantin Shalygin <k0ste@k0ste.ru>
-# Contributor: Theo von Arx <theova@member.fsf.org>
+# Maintainer: David P. <megver83@parabola.nu>
# parabola changes and rationale:
-# - removed qt5-webengine dependency
-
-
-pkgname=nextcloud-client
-pkgver=2.6.4
-_commit=b45f5fd1a947dc21eb11c69049a99616a2ec950e
+# - removed qt5-webengine dependency
+# - no changes necessary - simply rebuild without qt5-webengine in the environment
+
+pkgbase=nextcloud-client
+# Put config files for libcloudproviders integration in a separate package as
+# there is no simple way yet to disable it.
+# See: https://gitlab.gnome.org/World/libcloudproviders/-/issues/17
+pkgname=(nextcloud-client nextcloud-client-cloudproviders)
+epoch=2
+# Upstream does not provide signed tarballs (yet)
+# https://github.com/nextcloud/desktop/issues/1510
+pkgver=3.4.1
+# `git rev-parse v$pkgver`
+_tag=c1e1f91309b46f46d432ea0722e301ecaa094fb5
pkgrel=1
pkgrel+=.parabola1
-pkgdesc='Nextcloud desktop client'
-pkgdesc+=', without nonfree qt5-webengine dependency'
arch=(x86_64)
arch+=(i686 armv7h)
url='https://nextcloud.com/'
license=(GPL)
-depends=(openssl sqlite qtkeychain qt5-svg xdg-utils libcloudproviders)
-makedepends=(doxygen extra-cmake-modules kio python-sphinx qt5-tools git cmocka)
-optdepends=(
- 'kio: integration with Dolphin'
- 'nemo-python: integration with Nemo'
- 'python-nautilus: integration with Nautilus'
- 'python2-caja: integration with Caja'
-)
-source=("$pkgname::git+https://github.com/nextcloud/desktop.git?signed#commit=$_commit"
- issue1458-workaround.patch::https://github.com/yan12125/desktop/commit/7da680ef7843a52c3136916744f50d4a003bb8b5.patch
- issue1458-2.patch::https://github.com/yan12125/desktop/commit/2b313368325dac5b8d0e69394cfcc4faaa745f75.patch
- $pkgname-fix-build.diff
- Nextcloud.conf)
-source+=(remove-qtwebengine.patch)
+makedepends=(libcloudproviders openssl sqlite
+ qt5-quickcontrols2 qt5-svg qt5-tools qt5-websockets qtkeychain-qt5
+ extra-cmake-modules kio
+ cmocka doxygen git inkscape python-sphinx)
+source=("$pkgbase::git+https://github.com/nextcloud/desktop.git?signed#tag=$_tag"
+ fix-translations.patch)
validpgpkeys=(
A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # one of keys controlled by github.com/camilasan
42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # controlled by github.com/misch7
+ 17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
+ 01D736173523DFC7A7B55258C2FBEF0E1C7E72D0 # https://github.com/allexzander
+ 267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
+ 3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
)
sha256sums=('SKIP'
- '07cd68f54c004175b4a09cce25830a357d0ebaafaf4e4cabfb8b0d4deeded2f3'
- '157c87a789219a3442ca5947c48dcd1ef3898612ff32070bf8842a42bfbe857a'
- '8b257a0554ceb54a7ed320dbfa3becb97d6845338e28a8aa0a4f6239f3141645'
- '5f51e41ef01d4e5b88a4735531105b84b4fb5317adc2a2996117c03fe5a44fc7')
-sha256sums+=('77d7afd2dc65a7625e1617dd2c287c1be004deca2f64ecc18a96bb6c3cd733cf')
-backup=('etc/Nextcloud/sync-exclude.lst'
- 'etc/Nextcloud/Nextcloud.conf')
+ 'd112358031ddf79c08acde1f1b5e39aad9e3ee84ba161817d4f6e0259f9a5832')
+
+pkgver() {
+ cd $pkgbase
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
prepare() {
# tmpdir for check()
- mkdir tmpdir $pkgname/build
-
- # Use system GNUInstallDirs.cmake so that we can benefit from
- # https://gitlab.kitware.com/cmake/cmake/merge_requests/3735
- rm -v $pkgname/cmake/modules/GNUInstallDirs.cmake
+ mkdir tmpdir
- cd $pkgname
- patch -Np1 -i ../issue1458-workaround.patch
- patch -Np1 -i ../issue1458-2.patch
-
- # https://github.com/nextcloud/desktop/pull/719
- # "Rename owncloud tests to nextcloud" - actually breaks building of tests
- patch -Np1 -i ../$pkgname-fix-build.diff
-
- # Remove qt5-webengine dependency
- patch -Np1 -i ../remove-qtwebengine.patch
+ patch -d $pkgbase -p1 < fix-translations.patch # Fix loading translations
}
build() {
- cd $pkgname/build
+ cd $pkgbase
# bundled breakpad in libcrashreporter-qt submodule is too old and does not build with glibc >= 2.26
# Upstream fix: https://github.com/google/breakpad/commit/bddcc58860f522a0d4cbaa7e9d04058caee0db9d
- cmake \
+ cmake -B build -S . \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DNO_SHIBBOLETH=1 \
-DWITH_CRASHREPORTER=OFF \
-DUNIT_TESTING=ON \
- ..
+ -DPLUGINDIR=lib/qt/plugins # Fix vfs plugin install dir https://github.com/nextcloud/desktop/issues/3781#issuecomment-918918320
- make
# TODO: fix installation of PDF and HTML documents
# WIP at https://github.com/yan12125/desktop/tree/doc-install-path
- make doc-man
+ make -C build all doc-man
}
check() {
- cd $pkgname/build
+ cd $pkgbase/build
# Tests fail if $TMPDIR is too small; specify an alternative for machines
# with a small /tmp partition.
- TMPDIR="$srcdir/tmpdir" make test ARGS="-V"
+ # Use UTC as TestCookies is sensitive to the timezone
+ # https://github.com/nextcloud/desktop/blob/v3.2.2/test/testcookies.cpp#L24
+ QT_QPA_PLATFORM=offscreen TMPDIR="$srcdir/tmpdir" TZ=UTC ARGS="--rerun-failed --output-on-failure" make test
}
-package() {
- cd $pkgname/build
+package_nextcloud-client() {
+ pkgdesc='Nextcloud desktop client'
+ pkgdesc+=', without nonfree qt5-webengine dependency'
+ depends=(openssl sqlite qtkeychain-qt5 qt5-svg qt5-websockets xdg-utils libcloudproviders
+ qt5-graphicaleffects qt5-quickcontrols2)
+ optdepends=(
+ 'kio: integration with Dolphin'
+ 'nemo-python: integration with Nemo'
+ 'python-nautilus: integration with Nautilus'
+ 'python-caja: integration with Caja'
+ 'nextcloud-client-cloudproviders: cloudproviders support'
+ )
+ backup=('etc/Nextcloud/sync-exclude.lst')
+
+ cd $pkgbase/build
make DESTDIR="$pkgdir" install
- # Disables built-in update checker
- install -Dm644 "$srcdir/Nextcloud.conf" -t "$pkgdir"/etc/Nextcloud
+ rm -v "$pkgdir"/usr/share/cloud-providers/com.nextcloudgmbh.Nextcloud.ini
+ rm -v "$pkgdir"/usr/share/dbus-1/services/com.nextcloudgmbh.Nextcloud.service
+ cd "$pkgdir"/usr/share && rmdir -p cloud-providers dbus-1/services
+}
+
+package_nextcloud-client-cloudproviders() {
+ pkgdesc='cloudproviders support for the Nextcloud desktop client'
+ depends=(nextcloud-client)
+
+ cd $pkgbase/build
+ make -C shell_integration/libcloudproviders DESTDIR="$pkgdir" install
}