summaryrefslogtreecommitdiff
path: root/libre/nextcloud-client/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-12-02 20:17:45 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2019-12-03 22:32:33 -0500
commita35c13f49fac6e0836e22ea96882d400da634737 (patch)
treebb09a2f82c6f6268fb364d9c44cbec7e285d1ecf /libre/nextcloud-client/PKGBUILD
parent5d039079832b82f39184b7bc047fba4a5ae74d30 (diff)
[nextcloud-client]: bugfix PKGBUILD
Diffstat (limited to 'libre/nextcloud-client/PKGBUILD')
-rw-r--r--libre/nextcloud-client/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/libre/nextcloud-client/PKGBUILD b/libre/nextcloud-client/PKGBUILD
index d9103056b..69a997b48 100644
--- a/libre/nextcloud-client/PKGBUILD
+++ b/libre/nextcloud-client/PKGBUILD
@@ -26,7 +26,7 @@ optdepends=(
'python-nautilus: integration with Nautilus'
'python2-caja: integration with Caja'
)
-makedepends=('doxygen' 'extra-cmake-modules' 'kio' 'python-sphinx' 'qt5-tools' 'git cmocka')
+makedepends=('doxygen' 'extra-cmake-modules' 'kio' 'python-sphinx' 'qt5-tools' 'git' 'cmocka')
backup=(etc/Nextcloud/sync-exclude.lst)
source=($pkgname::git+https://github.com/nextcloud/desktop.git?signed#commit=$_commit
@@ -44,10 +44,10 @@ sha256sums=('SKIP'
prepare()
{
- cd $pkgname
+ cd "$srcdir/$pkgname/"
# tmpdir for check()
- mkdir tmpdir $pkgname/build
+ mkdir tmpdir "$srcdir/$pkgname/build"
# Use system GNUInstallDirs.cmake so that we can benefit from
# https://gitlab.kitware.com/cmake/cmake/merge_requests/3735
@@ -66,7 +66,7 @@ prepare()
build()
{
- cd $pkgname/build
+ cd "$srcdir/$pkgname/build"
# bundled breakpad in libcrashreporter-qt submodule is too old and does not build with glibc >= 2.26
# Upstream fix: https://github.com/google/breakpad/commit/bddcc58860f522a0d4cbaa7e9d04058caee0db9d
@@ -85,7 +85,10 @@ build()
check()
{
- cd $pkgname/build
+ cd "$srcdir/$pkgname/build"
+
+ # many tests fail on i686 and armv7h
+ [ "$CARCH" == 'i686' ] || [ "$CARCH" == 'armv7h' ] && return 0
# Tests fail if $TMPDIR is too small; specify an alternative for machines
# with a small /tmp partition.
@@ -94,7 +97,7 @@ check()
package()
{
- cd $pkgname/build
+ cd "$srcdir/$pkgname/build"
make DESTDIR="$pkgdir" install
}