summaryrefslogtreecommitdiff
path: root/libre/smplayer/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-02-04 18:11:01 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-02-04 18:12:09 -0300
commitb6102bebbcc7be38f224da95d8568a6ad8a5cc2e (patch)
tree8e98c9760004de177270ba2d42af19d0ae4eff1b /libre/smplayer/PKGBUILD
parenta8aa8497aacb86e6f0a984d114166981bc113374 (diff)
smplayer-17.2.0-1.parabola1: updating version
Diffstat (limited to 'libre/smplayer/PKGBUILD')
-rw-r--r--libre/smplayer/PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/libre/smplayer/PKGBUILD b/libre/smplayer/PKGBUILD
index 2c1a25136..10512420c 100644
--- a/libre/smplayer/PKGBUILD
+++ b/libre/smplayer/PKGBUILD
@@ -7,7 +7,7 @@
# Maintainer: André Silva <emulatorman@parabola.nu>
pkgname=smplayer
-pkgver=16.11.0
+pkgver=17.2.0
pkgrel=1.parabola1
pkgdesc='Media player with built-in codecs that can play virtually all video and audio formats, without nonfree smtube support'
url='http://smplayer.sourceforge.net/'
@@ -20,9 +20,11 @@ optdepends=('smplayer-themes: icon themes collection'
'youtube-dl: youtube videos and streaming'
'mplayer: alternative multimedia engine')
source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
- disable-smtube-support.patch)
-sha512sums=('13776ff134c4c91747fa9432080a4ea876d5d5a134b91dde48d0f0e75c280ef6d19067906e4e850da3b1b2287214914528743495cccf7cbda310bc51682b478c'
- '813efc30a754015d8bca9391ed3b586481c2cd931a0b234a8cb94cdad7ae92b8976aabd05569099900ce65b8f2fd39d39da0dddff46bfe10891dd5edc4f12283')
+ disable-smtube-support.patch
+ add-missing-QClipboard-include.patch)
+sha512sums=('dbe22c5bf7da4d4635b0d47837d3e03c12cea40ec4fbca58009567995547c4a065d35feb149d7ff3f799604f3107527ce4e1f564d860161ada84b499cb42d9c8'
+ '813efc30a754015d8bca9391ed3b586481c2cd931a0b234a8cb94cdad7ae92b8976aabd05569099900ce65b8f2fd39d39da0dddff46bfe10891dd5edc4f12283'
+ '619b8a236b36518bf0f9984d87384d9c5be10fdbda17598d57736064c0c2d6d9f920c9d3f1eb059ba390670ec28559f0dda6f85757ef8696540c424b08863e39')
prepare() {
cd $pkgname-$pkgver
@@ -30,6 +32,9 @@ prepare() {
# disable SMTube support
patch -p1 -i $srcdir/disable-smtube-support.patch
+ # add missing QClipboard include
+ patch -p1 -i $srcdir/add-missing-QClipboard-include.patch
+
# fix GNU/Linux name
sed -i 's|Linux|GNU/Linux|' src/smplayer.cpp
}