summaryrefslogtreecommitdiff
path: root/libre/file-roller/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/file-roller/PKGBUILD')
-rw-r--r--libre/file-roller/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/libre/file-roller/PKGBUILD b/libre/file-roller/PKGBUILD
index 424689c32..76f534643 100644
--- a/libre/file-roller/PKGBUILD
+++ b/libre/file-roller/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 225971 2014-11-10 23:29:29Z heftig $
+# $Id: PKGBUILD 231590 2015-02-15 17:41:18Z foutrelis $
# Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
pkgname=file-roller
pkgver=3.14.2
-pkgrel=1.parabola1
+pkgrel=2.parabola1
pkgdesc="Create and modify archives, with unar support included and nonfree unace recommendation removed"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL')
@@ -17,8 +17,15 @@ conflicts=("${pkgname}-libre" "${pkgname}-parabola")
options=('!emptydirs')
install=file-roller.install
url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
-sha256sums=('1815e736715afe8c0f3fbda41c76c07289220d4855345f779c632adf5e074e50')
+source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz
+ git-fixes.patch)
+sha256sums=('1815e736715afe8c0f3fbda41c76c07289220d4855345f779c632adf5e074e50'
+ 'd884ef16b2ce1e11967b7a14a34c164158c7008b3dc59e754b3478017696f5f9')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../git-fixes.patch
+}
build() {
cd $pkgname-$pkgver