summaryrefslogtreecommitdiff
path: root/libre/qtcreator/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qtcreator/PKGBUILD')
-rw-r--r--libre/qtcreator/PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/libre/qtcreator/PKGBUILD b/libre/qtcreator/PKGBUILD
index f76221351..d5b1dcfc2 100644
--- a/libre/qtcreator/PKGBUILD
+++ b/libre/qtcreator/PKGBUILD
@@ -13,11 +13,14 @@
# - added patch to build on arm
pkgname=qtcreator
-pkgver=4.5.0
+pkgver=4.5.2
_clangver=5.0.1
-pkgrel=2.parabola2
-pkgdesc='Lightweight, cross-platform integrated development environment, without nonfree qt5-webengine support'
-arch=(x86_64 i686 armv7h)
+pkgrel=1
+pkgrel+=.parabola2
+pkgdesc='Lightweight, cross-platform integrated development environment'
+pkgdesc+=', without nonfree qt5-webengine support'
+arch=(x86_64)
+arch+=(i686 armv7h)
url='http://qt-project.org'
license=(LGPL)
depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 clang=$_clangver qbs)
@@ -33,12 +36,11 @@ optdepends=('qt5-doc: integrated Qt documentation'
'mercurial: mercurial support'
'bzr: bazaar support'
'valgrind: analyze support')
-source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/${pkgver}/qt-creator-opensource-src-${pkgver}.tar.xz"
- '0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch'
- 'libre.patch')
-sha512sums=('9296ebef4a3d5ae40a9fa3a4039e77b8e407dfb52af3a88b4cc615a89e163d92de420d9db614bc689adc695879f0c2e1906e9a218e7a6b96c4b222d52c94912c'
- 'af0a0d5a2fadcfce14def65be73c99bff8227794b9ad2be333713c89e226e2c6b43802a802b6e30f3e6c1b4b77f31183bffdcca3404d9686f15fa84dfc64d1a1'
- 'a1be1d669e1a496ab8e975b925e4b2fa962fc268616deffa09163c42d62874adf210e47cd16ee375110ef53791bd84d53d115b422cef49ba98efbd552e99944c')
+source=("http://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz")
+source+=('0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch' 'libre.patch')
+sha256sums=('32fe9ffbb170d0461f6b010dcb0db4dd73c3b27cc575c760958507929975693a'
+ '56e6876f41ee8909ee197f7ab5a2bb18ad5a7fe26ce490a48cdf062fa199ffc6'
+ '14c2ded79d5e263f78a748afb5688b946ae243f3e7e4b765c198681c371d467c')
prepare() {
mkdir -p build
@@ -52,6 +54,8 @@ prepare() {
cd qt-creator-opensource-src-${pkgver}
patch -Np1 -i "$srcdir"/libre.patch
rm -rv src/plugins/help/webenginehelpviewer.{cpp,h}
+
+ # fix arm build
if [[ "$CARCH" == arm* ]]; then
git apply ../0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
fi