summaryrefslogtreecommitdiff
path: root/libre/qtcreator/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qtcreator/PKGBUILD')
-rw-r--r--libre/qtcreator/PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/libre/qtcreator/PKGBUILD b/libre/qtcreator/PKGBUILD
index 97d75167e..08ee3cc6f 100644
--- a/libre/qtcreator/PKGBUILD
+++ b/libre/qtcreator/PKGBUILD
@@ -1,4 +1,3 @@
-# Maintainer: bill-auger <bill-auger@programmer.net>
# Maintainer (Arch): Sven-Hendrik Haase <sh@lutzhaase.com>
# Maintainer (Arch): Antonio Rojas <arojas@archlinux.org>
# Contributor (Arch): Imanol Celaya <ornitorrincos@archlinux-es.org>
@@ -6,19 +5,22 @@
# Contributor (Arch): Dan Vratil <progdan@progdansoft.com>
# Contributor (Arch): thotypous <matiasΘarchlinux-br·org>
# Contributor (Arch): delor <bartekpiech gmail com>
+# Maintainer: bill-auger <bill-auger@programmer.net>
# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Theo von Arx <theova@member.fsf.org>
+
# parabola changes and rationale:
# - removed support for qt5-webengine
pkgname=qtcreator
-pkgver=4.10.2
+pkgver=4.11.0
_clangver=9.0.1
-pkgrel=1
-pkgrel+=.parabola2
+pkgrel=4
+pkgrel+=.parabola1
pkgdesc='Lightweight, cross-platform integrated development environment'
-pkgdesc+=', without nonfree qt5-webengine support'
+pkgdesc+=', without nonfree qt5-webengine help viewer'
arch=(x86_64)
arch+=(i686 armv7h)
url='https://www.qt.io'
@@ -39,10 +41,11 @@ optdepends=('qt5-doc: integrated Qt documentation'
'perf: performer analyzer')
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
qtcreator-preload-plugins.patch)
-source+=('libre.patch')
-sha256sums=('9add6bdddfe5726bb02535409c2ed788b1afeee082121f54f887281d0e3c449a'
- '150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d')
-sha256sums+=('b44b9217770573b16e7bea873b0a0fb1b9f6f59502686eb6136d78bebc671ddb')
+source+=(libre.patch)
+sha256sums=('efebaa1c52526bf9c07b35c43071735c5d0b83b6cd08daab35a21e7ed53a7645'
+ 'd6f979c820e2294653f4f1853af96942bf25ff9fe9450657d45ff1c7f02bbca7')
+sha256sums+=('6aeac164075b7f3f3a2e9aa75865669beeeb7903b9cbb5b6a8700205b285fe64')
+
prepare() {
mkdir -p build