summaryrefslogtreecommitdiff
path: root/libre/qtcreator/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qtcreator/PKGBUILD')
-rw-r--r--libre/qtcreator/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/libre/qtcreator/PKGBUILD b/libre/qtcreator/PKGBUILD
index 994c79e47..6432e5cf7 100644
--- a/libre/qtcreator/PKGBUILD
+++ b/libre/qtcreator/PKGBUILD
@@ -10,9 +10,9 @@
pkgname=qtcreator
pkgver=4.2.1
_pkgver=v4.2.1
-pkgrel=3.parabola1
+pkgrel=3.parabola1.1
pkgdesc='Lightweight, cross-platform integrated development environment, without nonfree qt5-webengine support'
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url='http://qt-project.org'
license=('LGPL')
depends=('qt5-tools' 'qt5-declarative' 'qt5-script' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'clang' 'qbs')
@@ -29,14 +29,20 @@ optdepends=('qt5-doc: integrated Qt documentation'
'bzr: bazaar support'
'valgrind: analyze support')
source=("http://download.qt.io/official_releases/qtcreator/4.2/${pkgver}/qt-creator-opensource-src-${pkgver}.tar.xz"
- 'libre.patch')
+ 'libre.patch'
+ '0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch')
sha512sums=('3135b64a36240bffe41c1373d5e5d5327cfa556f42eb339afcacf2f8d294843b96269269417ab262ba8292e28a57472c78ab7ff4686f0360616a4014c75809e9'
- '57dd505e183661463567b6a7711a7b58f1d5e5b6ecc808acbae4df78366ed3d08be9eb04f6883ad8fd15318c826645e655e7028136b16a801e0084d3a2b51b2a')
+ '57dd505e183661463567b6a7711a7b58f1d5e5b6ecc808acbae4df78366ed3d08be9eb04f6883ad8fd15318c826645e655e7028136b16a801e0084d3a2b51b2a'
+ 'af0a0d5a2fadcfce14def65be73c99bff8227794b9ad2be333713c89e226e2c6b43802a802b6e30f3e6c1b4b77f31183bffdcca3404d9686f15fa84dfc64d1a1')
prepare() {
cd $srcdir/qt-creator-opensource-src-$pkgver
patch -p1 -i ../libre.patch
rm -rv src/plugins/help/webenginehelpviewer.{cpp,h}
+
+ if [[ "$CARCH" =~ ^arm*|^aarch64$ ]]; then
+ git apply ../0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
+ fi
}
build() {