summaryrefslogtreecommitdiff
path: root/libre/qtcreator/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/qtcreator/PKGBUILD')
-rw-r--r--libre/qtcreator/PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/libre/qtcreator/PKGBUILD b/libre/qtcreator/PKGBUILD
index c5d4d9ccc..7bdbf3d83 100644
--- a/libre/qtcreator/PKGBUILD
+++ b/libre/qtcreator/PKGBUILD
@@ -13,8 +13,8 @@
pkgname=qtcreator
-pkgver=4.9.2
-_clangver=8.0.1
+pkgver=4.10.1
+_clangver=9.0.0
pkgrel=1
pkgrel+=.parabola1
pkgdesc='Lightweight, cross-platform integrated development environment'
@@ -23,8 +23,7 @@ arch=(x86_64)
arch+=(i686 armv7h)
url='https://www.qt.io'
license=(LGPL)
-depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 \
- clang=$_clangver qbs clazy syntax-highlighting desktop-file-utils)
+depends=(qt5-tools qt5-quickcontrols qt5-quickcontrols2 clang=$_clangver qbs clazy syntax-highlighting desktop-file-utils)
makedepends=(llvm python patchelf)
options=(docs)
optdepends=('qt5-doc: integrated Qt documentation'
@@ -39,14 +38,12 @@ optdepends=('qt5-doc: integrated Qt documentation'
'valgrind: analyze support'
'perf: performer analyzer')
source=("https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.xz"
- qtcreator-clazy-1.5.patch
qtcreator-preload-plugins.patch
- qtcreator-mime-database.patch)
+ qtcreator-clang-9.patch)
source+=('libre.patch')
-sha256sums=('b7e0c797e7704c6c22eb35351946c0a758502fd082f6beaee043166e1739d3d7'
- '1f6998fea92b9a157f42cca783839ce95f70ccc667027078b7881cbb253838f0'
+sha256sums=('5098d87027bec3296bd93a7e112588759ccb0511fbfdc5558c1a1e83dff8d2a9'
'150c444e76ec969fc8765774b648984037829623300d0ce9d41a915b2afa792d'
- '8d64b5c28535dcaab910f32e82b04b425253015ca70f379cbe5e9693526a852a')
+ '1d66eb008e84459f6570e6e72acedcf80d2f0bb82650df3b733f7ca0a3f08a3d')
sha256sums+=('b44b9217770573b16e7bea873b0a0fb1b9f6f59502686eb6136d78bebc671ddb')
prepare() {
@@ -58,13 +55,12 @@ prepare() {
sed -e 's|libexec|lib|g' -i src/tools/tools.pro
# use system qbs
rm -r src/shared/qbs
- # Adapt to clazy 1.5 plugin rename
- patch -p1 -i ../qtcreator-clazy-1.5.patch
# Preload analyzer plugins, since upstream clang doesn't link to all plugins
# see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
# and https://bugs.archlinux.org/task/59492
patch -p1 -i ../qtcreator-preload-plugins.patch
- patch -p1 -i ../qtcreator-mime-database.patch # Use system shared-mime-info
+ # Fix build with clang 9 (Fedora)
+ patch -p1 -i ../qtcreator-clang-9.patch
# remove qt5-webengine support
patch -Np1 -i "$srcdir"/libre.patch
@@ -91,6 +87,6 @@ package() {
install -Dm644 "$srcdir"/qt-creator-opensource-src-$pkgver/LICENSE.GPL3-EXCEPT "$pkgdir"/usr/share/licenses/qtcreator/LICENSE.GPL3-EXCEPT
- # Link clazy plugin explicitely
+# Link clazy plugin explicitely
patchelf --add-needed ClazyPlugin.so "$pkgdir"/usr/lib/qtcreator/clangbackend
}