summaryrefslogtreecommitdiff
path: root/pcr/ocaml-curl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/ocaml-curl/PKGBUILD')
-rw-r--r--pcr/ocaml-curl/PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/pcr/ocaml-curl/PKGBUILD b/pcr/ocaml-curl/PKGBUILD
index 40cb3f217..10854827b 100644
--- a/pcr/ocaml-curl/PKGBUILD
+++ b/pcr/ocaml-curl/PKGBUILD
@@ -1,29 +1,27 @@
-# Contributor (Arch) : Serge Zirukin <ftrvxmtrx@gmail.com>
-# Contributor (Arch) : Sergei Lebedev <superbobry@gmail.com>
-# Contributor (Arch) : Justin Davis <jrcd 83 at gmail>
+# Maintainer (AUR) : Eric Bailey <nerflad@gmail.com>
# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
pkgname=ocaml-curl
-pkgver=0.5.3
-pkgrel=5
+pkgver=0.8.2
+pkgrel=1
pkgdesc="OCaml bindings to libcurl networking library"
-arch=('i686' 'x86_64')
-license=('MIT')
-depends=('ocaml' 'curl>=7.9.8')
+arch=('i686' 'x86_64' 'armv7h')
+license=('BSD')
+depends=('ocaml' 'curl>=7.28.0')
makedepends=('ocaml-findlib')
options=('!strip' '!makeflags' 'staticlibs')
-url='http://sourceforge.net/projects/ocurl/'
-source=("http://sourceforge.net/projects/ocurl/files/ocurl/$pkgver/ocurl-$pkgver.tgz")
-md5sums=('c8b955e51f79dd2c62ab89577b27fe37')
+url='https://github.com/ygrek/ocurl'
+source=("${url}/releases/download/${pkgver}/ocurl-${pkgver}.tar.gz")
+sha256sums=('09830f496aea805ecd4593834acc51852803ebe336650eda793facf769eba3ab')
build() {
- cd "$srcdir/ocurl"
+ cd "$srcdir/ocurl-${pkgver}"
./configure --prefix /usr
make
}
package() {
- cd "$srcdir/ocurl"
+ cd "$srcdir/ocurl-${pkgver}"
export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
install -dm 755 "$OCAMLFIND_DESTDIR/stublibs"
make install FINDLIB=ocamlfind