summaryrefslogtreecommitdiff
path: root/pcr/python2-dukpy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/python2-dukpy/PKGBUILD')
-rw-r--r--pcr/python2-dukpy/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/pcr/python2-dukpy/PKGBUILD b/pcr/python2-dukpy/PKGBUILD
new file mode 100644
index 000000000..b7916c824
--- /dev/null
+++ b/pcr/python2-dukpy/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor (arch): Jelle van der Waa <jelle@archlinux.org>
+# Contributor (arch): Eli Schwartz <eschwartz93@gmail.com>
+# Maintainer: bill-auger <bill-auger@programmer.net>
+
+
+pkgname=('python2-dukpy')
+pkgver=0.3
+pkgrel=4
+pkgdesc="Python bindings for the duktape embeddable JavaScript engine"
+arch=(armv7h i686 x86_64)
+url=https://github.com/kovidgoyal/dukpy
+license=('MIT')
+
+makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python2')
+source=(https://github.com/kovidgoyal/dukpy/archive/v${pkgver}.tar.gz)
+
+sha256sums=('cc78c39ebba51f381c623b164cfb7dcf3caddf515fe7094bc53b7eca5d4e435e')
+
+
+build()
+{
+ cd "${srcdir}/dukpy-${pkgver}"
+
+ python2 setup.py build
+}
+
+check()
+{
+ cd "${srcdir}/dukpy-${pkgver}"
+
+ python2 setup.py test
+}
+
+package()
+{
+ cd "${srcdir}/dukpy-${pkgver}"
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/python2-dukpy/LICENSE.txt
+}