summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-09-03 22:31:38 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-09-03 22:36:10 -0400
commit04fd0fbd253507868eea2c689abe013519fe8696 (patch)
tree0e82653406632db0d61db80552b6203b1d96e4c8
parentcdc9333ec1317ebf00ad80b8c9541dc5b2776351 (diff)
-rw-r--r--Makefile2
-rwxr-xr-xcron-jobs/check_archlinux/parse_pkgbuilds.sh1
-rwxr-xr-xcron-jobs/devlist-mailer2
-rwxr-xr-xcron-jobs/update-web-db8
-rw-r--r--test/cases/common.bats1
5 files changed, 9 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 5016420..c53873b 100644
--- a/Makefile
+++ b/Makefile
@@ -18,7 +18,7 @@ sh_bash = $(shell git grep -l '^\#!.*\bbash\b')
sh_bats = $(shell git ls-files 'test/cases/*.bats')
lint: $(sh_bash) $(patsubst %.bats,%.sh,$(sh_bats)) test/PKGBUILD.proto
- shellcheck $^
+ shellcheck --exclude=2164 -- $^
test/cases/%.sh: test/cases/%.bats
/usr/lib/bats/bats-preprocess < $< > $@
diff --git a/cron-jobs/check_archlinux/parse_pkgbuilds.sh b/cron-jobs/check_archlinux/parse_pkgbuilds.sh
index f470342..144be43 100755
--- a/cron-jobs/check_archlinux/parse_pkgbuilds.sh
+++ b/cron-jobs/check_archlinux/parse_pkgbuilds.sh
@@ -150,6 +150,7 @@ if [[ -z "$1" || -z "$2" ]]; then
exit 1
fi
+# shellcheck disable=SC2034
CARCH=$1
shift
for dir in "$@"; do
diff --git a/cron-jobs/devlist-mailer b/cron-jobs/devlist-mailer
index a0155a5..0087fc4 100755
--- a/cron-jobs/devlist-mailer
+++ b/cron-jobs/devlist-mailer
@@ -17,7 +17,7 @@ fi
stdin="$(cat)"
#echo used to strip whitespace for checking for actual data
-# shellcheck disable=SC2086
+# shellcheck disable=SC2086,SC2116
if [[ -n "$(echo $stdin)" ]]; then
echo "Subject: $SUBJECT
diff --git a/cron-jobs/update-web-db b/cron-jobs/update-web-db
index 1357059..8be5632 100755
--- a/cron-jobs/update-web-db
+++ b/cron-jobs/update-web-db
@@ -64,9 +64,11 @@ for repo in "${REPOS[@]}"; do
for arch in "${ARCHES[@]}"; do
dbcopy="${WORKDIR}/${repo}/${arch}/${repo}${dbfileext}"
if [[ -f ${dbcopy} ]]; then
- echo "Updating ${repo}-${arch}" >> "${LOGOUT}"
- ./manage.py reporead "${flags}" "${arch}" "${dbcopy}" >> "${LOGOUT}" 2>&1
- echo "" >> "${LOGOUT}"
+ {
+ echo "Updating ${repo}-${arch}"
+ ./manage.py reporead "${flags}" "${arch}" "${dbcopy}" 2>&1
+ echo ""
+ } >> "${LOGOUT}"
fi
done
done
diff --git a/test/cases/common.bats b/test/cases/common.bats
index 313e079..0579bba 100644
--- a/test/cases/common.bats
+++ b/test/cases/common.bats
@@ -3,6 +3,7 @@
load ../lib/common
@test "commands display usage message by default" {
+ local cmd
for cmd in db-move db-remove db-repo-add db-repo-remove testing2x; do
echo Testing $cmd
run $cmd